Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: xAPTel and xAPSwitcboard

  1. #1
    Automated Home Jr Member
    Join Date
    Feb 2011
    Posts
    22

    Default xAPTel and xAPSwitcboard

    Hi,

    Tried xAPautomation with the following query, no replies hopefully someone here can help.
    Only just discovered xAP, I think xAPtel is broadcasting messages but not recieving them from xAPswitchboard.
    xAPTel version is beta3 and switchboard is 1.2 I think. Have tried to locate newer version.

    Have installed xAPTel and xAPswitchboard have Pegasus unit installed.

    Incoming call everything works fine calls are logged, manually dialled outgoing
    calls show up in the log.

    When I click the telephone to dial a number get the screen

    Dial number 1234-456789

    with a button below dial using

    UKUSA.Tel.voiceall:cawdor

    I named the line cawdor

    when I press this get the screen

    Dialing Number


    0xxx0 6xxx44


    Pick up your telephone handset

    I pick the phone go off hook

    nothing happens xAPtel does not show any messages until I take the phone of the
    hook. Here are the messages from xFxviewer

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CTI.event
    source=UKUSA.Tel.voiceall:cawdor
    }
    Line
    {
    Network=PSTN
    Dialler=PSTN
    Country=44
    LineState=Outgoing
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CID.Meteor
    source=UKUSA.Tel.voiceall:cawdor
    }
    Outgoing.CallInitiated
    {
    Network=
    DateTime=20121218005344
    Type=
    Tag=0
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CID.Meteor
    source=UKUSA.Tel.voiceall:cawdor
    }
    Outgoing.CallComplete
    {
    DateTime=20121218005355
    Duration=00:00:10
    Phone=
    Tag=0
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CID.Meteor
    source=UKUSA.Tel.voiceall:cawdor
    }
    Outgoing.CallTerminated
    {
    DateTime=20121218005355
    Duration=00:00:10
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CTI.event
    source=UKUSA.Tel.voiceall:cawdor
    }
    Line
    {
    Network=PSTN
    Dialler=PSTN
    Country=44
    LineState=Free
    }

    I am assuming the part where it shows Phone=

    no number shows.

    I have been expirementing getting Girder 5 to and xAPTel
    can pick up the info broadcast.
    Hope to eventually have GIRDER to carry out action via the phone.

    In the settings under lines tried setting xAP source as

    UKUSA.Tel.voiceall:cawdor ie xAPtel
    also tried
    mi4.switchboard.CINEMA-PC ie xAPswitchboard
    also no entries

    Any help greatly appreciated

    Oh one other thing in girder message
    Ring always =0

    Hope somone can help

  2. #2
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    500

    Default

    It's been a long long time since I used xAPTel but I'll take a look at this although it's not something I'm likely to be able do before Xmas and maybe not even before New year as I am away a lot over that time.. I also don't have a Pegasus any more to test with.

    Can I assume that xAP switchboard and xAPTel are both running on the same PC... and that you have installed a xAP hub on that PC and it was started and running before both xAPTel and xAP Switchboard were launched ?

    Kevin


    Quote Originally Posted by jolly1 View Post
    Hi,

    Tried xAPautomation with the following query, no replies hopefully someone here can help.
    Only just discovered xAP, I think xAPtel is broadcasting messages but not recieving them from xAPswitchboard.
    xAPTel version is beta3 and switchboard is 1.2 I think. Have tried to locate newer version.

    Have installed xAPTel and xAPswitchboard have Pegasus unit installed.

    Incoming call everything works fine calls are logged, manually dialled outgoing
    calls show up in the log.

    When I click the telephone to dial a number get the screen

    Dial number 1234-456789

    with a button below dial using

    UKUSA.Tel.voiceall:cawdor

    I named the line cawdor

    when I press this get the screen

    Dialing Number


    0xxx0 6xxx44


    Pick up your telephone handset

    I pick the phone go off hook

    nothing happens xAPtel does not show any messages until I take the phone of the
    hook. Here are the messages from xFxviewer

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CTI.event
    source=UKUSA.Tel.voiceall:cawdor
    }
    Line
    {
    Network=PSTN
    Dialler=PSTN
    Country=44
    LineState=Outgoing
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CID.Meteor
    source=UKUSA.Tel.voiceall:cawdor
    }
    Outgoing.CallInitiated
    {
    Network=
    DateTime=20121218005344
    Type=
    Tag=0
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CID.Meteor
    source=UKUSA.Tel.voiceall:cawdor
    }
    Outgoing.CallComplete
    {
    DateTime=20121218005355
    Duration=00:00:10
    Phone=
    Tag=0
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CID.Meteor
    source=UKUSA.Tel.voiceall:cawdor
    }
    Outgoing.CallTerminated
    {
    DateTime=20121218005355
    Duration=00:00:10
    }

    xap-header
    {
    v=12
    hop=1
    uid=FF233201
    class=CTI.event
    source=UKUSA.Tel.voiceall:cawdor
    }
    Line
    {
    Network=PSTN
    Dialler=PSTN
    Country=44
    LineState=Free
    }

    I am assuming the part where it shows Phone=

    no number shows.

    I have been expirementing getting Girder 5 to and xAPTel
    can pick up the info broadcast.
    Hope to eventually have GIRDER to carry out action via the phone.

    In the settings under lines tried setting xAP source as

    UKUSA.Tel.voiceall:cawdor ie xAPtel
    also tried
    mi4.switchboard.CINEMA-PC ie xAPswitchboard
    also no entries

    Any help greatly appreciated

    Oh one other thing in girder message
    Ring always =0

    Hope somone can help

  3. #3
    Automated Home Jr Member
    Join Date
    Feb 2011
    Posts
    22

    Default

    Hi Kevin
    Both on Same PC running windows 7 64 bit. Hub is xFX

    Thanks for taking a look

  4. #4
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    500

    Default

    Quote Originally Posted by jolly1 View Post
    I have been expirementing getting Girder 5 to and xAPTel
    can pick up the info broadcast.
    Hope to eventually have GIRDER to carry out action via the phone.
    I'm a little unsure of your intent here - are you saying you want to get Girder to intercept the dial requests from Switchboard and action them (rather than xAPTel) ? So Girder has it's own modem/dialler ? Also you say that xAPTel can pick up the info broadcast from Girder... how do you know that .. as that would mean that xAPTel is not deaf to xAP traffic ?

    Can you paste the message immediately before your sequence where Switchboard is sending the dial request ... and also one earlier one from xAPTel where it is advertising the lines that it has available to dial out on... I can't just at the moment remember the class of that message.

    Also can you confirm that the Pegasus does dial correctly when you action that from a serial terminal program, the 'Hayes' command you used and that it was required to take the phone offhook manually for the call to be placed ... rather than the Pegasus hardware being able to do this itself...

    K

  5. #5
    Automated Home Jr Member
    Join Date
    Feb 2011
    Posts
    22

    Default

    Hi Kevin,
    Revisting the schema, final started to understand how the messages should be structured.

    first message sent

    xap-header
    {
    v=12
    hop=1
    uid=FF430000
    class=CTI.cmd
    source=promixis.girder.server
    }

    Dial
    {
    Phone=07590 xxx444
    Duration=20
    Tag=4
    }

    Then after a few seconds

    xap-header
    {
    v=12
    hop=1
    uid=FF430000
    class=CTI.cmd
    source=promixis.girder.server
    }

    Offhook
    {
    Network=PSTN
    Phone=07590 601444
    Tag=4
    }


    xPtel does not respond to these so after 20 or so seconds send


    xap-header
    {
    v=12
    hop=1
    uid=FF430000
    class=CTI.cmd
    source=promixis.girder.server
    }

    Onhook
    {
    Phone=07590 601444
    Tag=4
    }


    xaPtel does not respond, have I structered the message correctly

  6. #6
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    500

    Default

    I'm really snowed under just at the moment and haven't had time to look back at what was implemented way back then... but I expect that there needs to be a target= line in the header that addresses xAPTel and maybe even the line required.... That's why I asked to see the CTI.cmd messages as sent by xAP Switchboard and also the CTI.event or CTI.info which announces line availability.

    I'm sure you've seen the schema definition on the mi4 site .. but I'm confused as to what you're trying to do with Girder... it would be better to try and get this working with known good messages (that switchboard sends) first. Plus you really need to remove the extra LF after the header block as that also could cause xAPTel to ignore the message creating another unknown.

    K

    http://www.mi4.biz/modules.php?name=...howpage&pid=49
    http://www.mi4.biz/modules.php?name=...howpage&pid=50

  7. #7
    Automated Home Jr Member
    Join Date
    Feb 2011
    Posts
    22

    Default

    Kevin,
    Carried out search of c:\ for xAPAX.ocx and it cannot be found is this the problem?

  8. #8
    Automated Home Jr Member
    Join Date
    Feb 2011
    Posts
    22

    Default

    Kevin,
    Tried searching MI4.biz and cannot find the file. Tried http://patrick.lidstone.net/html/dev_tools.html when I click on xAP Active x, I get the following xapax_17.vwz ??

  9. #9
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    500

    Default

    That isn't the issue.... if the OCX wasn't there then you would get a runtime error thrown... and also xAPTel wouldn't be able to send xAP messages, and Switchboard would fail too.

    Just FYI the download link on mi4's site is
    http://www.mi4.biz/modules.php?name=...rticle&sid=151

    There are several OCX's for xAP use - the one used in Switchboard and the last released xAPTel is the mi4 one. Patricks OCX has a memory leak that was never fixed and so xAPTel was swapped to the mi4 one.

    K

  10. #10
    Automated Home Jr Member
    Join Date
    Feb 2011
    Posts
    22

    Default

    Kevin
    thanks for that I take it the second set of commands couple of messages above are Ok.

    I did manage to send commands from girder to xAPswitchboard as if xAPtel were sending them and worked Ok, so coms from girder xAP bus seems ok.

    From girder I reated a basic lua script to the pegasus unit can get both incoming and outgoing call info.

    I have really only started using xAP and so far well impressed by the simplicity and capabilities so thanks for that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •