Search:

Type: Posts; User: Evo user

Search: Search took 0.00 seconds.

  1. Replies
    11
    Views
    529

    Thank you very much all. I've gone through the...

    Thank you very much all. I've gone through the tips and here's what I found:

    filbert - yes, I think an air lock isn't the issue as the radiators do function with TRVs

    Stevedh - I don't have the...
  2. Replies
    11
    Views
    529

    Thanks v much both, I will test both these...

    Thanks v much both, I will test both these thoughts and report back.
  3. Replies
    11
    Views
    529

    I'm with you. Actually one of them did need an...

    I'm with you. Actually one of them did need an adapter but the other three all fit on in the same way so I don't think it's that. When they were installed all the zones worked no problem but at some...
  4. Replies
    11
    Views
    529

    Hi BuxtonJim. Many thanks - yes, I tightened all...

    Hi BuxtonJim. Many thanks - yes, I tightened all 4 and made sure they fitted on properly and latched on. Not sure what you mean about the "valve bodies" - the actuators all fit on in the same way as...
  5. Replies
    11
    Views
    529

    Evohome zone problem.

    Hmmm, can't figure this one out.

    I have a zone on the top floor of my house with 4 actuators however which simply won't kick their radiators into life. The radiators all work fine with TRVs on and...
  6. Replies
    2
    Views
    167

    Thank you! It wasn't that in the event, it was...

    Thank you! It wasn't that in the event, it was that I was mistakenly trying to use the evohome controller as the heating control in multiple zones.
  7. Replies
    2
    Views
    167

    Zones keep saying "not bound"

    Hello, I am having a new problem with my evohome set up. I have 12 zones and, after deleting one and rebinding the actuators again, I find that the binding goes after a short period of time. I have...
Results 1 to 7 of 7