Results 1 to 6 of 6

Thread: 3 Port Valve / Thermostat Fault

  1. #1
    Automated Home Lurker
    Join Date
    Jan 2007
    Posts
    3

    Unhappy 3 Port Valve / Thermostat Fault

    I seem to be having problems with the three port valve. When the hot water is calling for heat and the room stat has switched of the rads continue to get hot. When the cylinder stat is not calling for heat the room stat works fine. I have taken the top off the valve and it seems to work fine, any ideas.
    Andyman

  2. #2
    Moderator sunbeam's Avatar
    Join Date
    Feb 2006
    Location
    lancs
    Posts
    261

    Default

    has it just started doing this?

    how old is the valve?

    sometimes the ball inside the valve gets swolen with age preventing it from motering over.

  3. #3
    Automated Home Lurker
    Join Date
    Jan 2007
    Posts
    3

    Default

    The valve was replaced last August, the problem started at Christmas. It got hot one day when we had a houseful, turned down the stat and we got hotter. Was ok then for a week or so and has given probs over the last week or so

  4. #4
    Moderator sunbeam's Avatar
    Join Date
    Feb 2006
    Location
    lancs
    Posts
    261

    Default

    so when the hot water is not calling for heat and the room stat is tuned down, the boiler turns off?

  5. #5
    Automated Home Lurker
    Join Date
    Jan 2007
    Posts
    3

    Default

    Correct. If i turn down the hot water stat or turn off hot water at the programmer the heating is fine.

  6. #6
    Moderator sunbeam's Avatar
    Join Date
    Feb 2006
    Location
    lancs
    Posts
    261

    Default

    Iíd say Itís your valve, the ball isnít blocking the central heating port off.

    When itís on heating only, the boiler the boiler room stat will turn off the boiler.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •