Results 1 to 3 of 3

Thread: Overflow

  1. #1
    Automated Home Lurker
    Join Date
    Dec 2007
    Posts
    1

    Default Overflow

    Hi guys,
    I have a Baxi Bermuda back boiler.
    Last week it stopped working.
    On inspection a leak had burnt out mid-position valve.
    This was renewed along with pump.
    The heating and water is now working fine but
    every time the boiler fires up water is being lost up
    the overflow into header tank which is in a bedroom
    and is noisy.
    The pump has been changed again and is still the same.
    Any ideas.
    Cheers

  2. #2
    Automated Home Legend TimH's Avatar
    Join Date
    Feb 2004
    Location
    UK
    Posts
    503

    Default

    I'm not familiar with that particular boiler but can offer a couple of suggestions.

    Does the pump have a speed control dial? If so, is it set the same as the original pump? If its set higher, maybe there's a greater whoosh (technical term...) when the system fires up, causing a bit of water to be pushed over via the overflow.

    Even if the pump doesn't have speed control, is the new one the same capacity as the original? If its greater, you may get the same effect as above.

    Does the pump have isolation valves, and have these been opened *fully* after changing the pump?

    HTH,

    Tim.

  3. #3
    Moderator sunbeam's Avatar
    Join Date
    Feb 2006
    Location
    lancs
    Posts
    261

    Default

    i reckon the cold feed to the system is blocked

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •