Results 1 to 3 of 3

Thread: baxi 80e ,water and heating on together problem ??

  1. #1
    Automated Home Lurker
    Join Date
    Jul 2008
    Posts
    2

    Default baxi 80e ,water and heating on together problem ??

    can anyone help me please. i have a baxi 80e that is about 4 years old . the problem is that the radiators are coming on with the hot water when the switch is set to hot water only ?. when you turn the hot water tap off the boiler stops as it should and 3 seconds later, kicks in again heating the rads. i have to keep turning boiler off, and back on when and as i need it. ive changed the board and the diaghram but still the same ? any help would be much appreciated....cheers keeny

  2. #2
    Moderator toscal's Avatar
    Join Date
    Oct 2005
    Location
    Near Alicante Spain
    Posts
    2,019

    Default

    There may be something now trapped in the diaphragm valve thingy preventing it from closing properly. Might be worth dismantling it again and checking. Is there any water coming from the overflow valve.
    IF YOU CAN'T FIX IT WITH A HAMMER, YOU'VE GOT AN ELECTRICAL PROBLEM.
    www.casatech.eu Renovation Spain Blog

  3. #3
    Automated Home Lurker
    Join Date
    Jul 2008
    Posts
    2

    Question

    Quote Originally Posted by toscal View Post
    There may be something now trapped in the diaphragm valve thingy preventing it from closing properly. Might be worth dismantling it again and checking. Is there any water coming from the overflow valve.
    I did give it a good clean before i fitted the new diaphram, could it be the smaller diaphram on the unit that i need possibly ? cheers keeny

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •