I have been messing round with X10 for a couple of years now and overall have had poor experiences. This may be because I don't iron out the problems when they surface.

So here goes: May be someone can help with my long term problems and show my wife that it wasn't all a big waste of time / effort / money. lol

I have a SC9000 security control center. I have the KR21 remotes which alarm and disarm the system perfectly. However the lights on and lights off do not operate A1 and A2 like they should.
I have tried to change the A1 and A2 to D1 and D2 and other codes, but all with no luck. So I gave up.

All of the lights (8 in total) work perfectly most of the time. The ones operated by the MS13 sensors are unreliable and don't switch on every time. Again this is a long term problem which I have just shelved, putting it down to the location of the MS13.

I got a second (probably 12th) wind after Christmas and decided to buy some plug in units to operate some lamps. (Energy saving bulbs - so using appliance plug ins). I plugged the first unit in last night next to the TM13 and programmed the unit to L9. Perfect. I then went to the other end of the same room, plugged in the unit and sent the X10 command but nothing happened.
Thinking I had a dodgy plug unit I swapped it for another and tried again - no luck.
I then took the unit I had already programmed but that didn't operate in that socket either!
I changed to the other socket in the double gang and still no luck.
I took the same unit into the kitchen and it worked.

It was a little late last night so I decided to either smash all the units with a hammer or go to bed. As the hammer was somewhere in the garage I decided on bed.

Laying in bed for a few hours I have logically narrowed it down to a few problems. Can anyone (if you are still reading) help elliminate or comment on any of them?

1. To much noise or interferance.
2. Length of cable between TM13 and plug in unit.
3. Wiring problem to the tested sockets.

I will carry out the following tests tonight to try and close down the issue:
A. plug the TM13 into the socket next to the dodgy socket.
B. Move the TM13 nearer to the main fuse box.

Do you think this is related to the SC9000 problem?

Are MS13's prety unreliable, or it just mine?

All / any help or comments would be greatly appreciated


PS: The house is only two years old so I am assuming has been wired to modern standards. There is even a neutral wire to each of the light switches, which saved me hours of messing.