Results 1 to 6 of 6

Thread: Welcome to the xAP Flash forum

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    554

    Default Welcome to the xAP Flash forum



    xAP Flash is a touchscreen based home automation control application written originally for the O2 Joggler. Because it is coded in Flash it can also run on many other devices including Android , Windows mobile, WebOS and also standalone or within most web browsers on a PC . It doesn't however run on the Apple iPhone, iPad or iPod Touch as these devices 'famously' don't support Flash. Apple's Safari web browser on a Mac/PC does work well though.

    xAP Flash controls xAP based devices and can integrate with leading home automation software applications that have xAP plugins available, as most do.

    xAP Flash is a hobbyist project I wrote for my own interest when I got my Jogglers, my first ever experience with Flash. There have been a dozen or so beta testers and now it is available for anyone to explore although it will likely always remain in progress / a beta release.

    Due to limited time I am hoping that existing users will be able to support each other here with help, improved documentation, tips, example screen layouts , graphics etc. and if that works well then I'll look to releasing later versions, with added features. Brett has embedded xAPFlash in the Home Automation Hub and there is a great help wiki

    Any general xAP questions should be posted in the parent xAP forum.

    The latest version will always be linked to from here:

    b 0.5g download

    K

    0.5g corrects an issue where labels on externally loaded dual icons displayed incorrectly
    Last edited by Kevin; 17th January 2012 at 01:46 PM.

  2. #2
    Automated Home Sr Member BodgeIT's Avatar
    Join Date
    Jul 2010
    Posts
    57

    Default broken slider?

    Hi Kevin,
    Happy New Year to you.
    I've started to get back into all things HAH & xAP. Having updated to this release I noticed that it seemed to break my slider buttons.
    Code:
    	<button NAME="Volume">
    			<gridX>1</gridX>
    			<gridY>3</gridY>
    			<posY>-20</posY>
    			<visible>true</visible>
    			<xAP>
    				<schema>xAPBSC</schema>
    				<uid>FF.0D7D1610:0002</uid>
    				<source>ersp.SlimServer.Stargate:Kitchen</source>
    			</xAP>
    			<mode>slider</mode>
    			<slider>
    				<type>embedded</type>
    				<style>o2slider</style>
    				<rotation>horizontal</rotation>
    				<latency>100</latency>
    			</slider>
    		</button>
    I'm aware syntax has changed but I've checked against the examples provided and my config appears OK.

    Any suggestions?

    Thanks
    Gary

  3. #3
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    554

    Default

    Try changing ..

    <style>o2slider</style>
    to
    <design>o2</design>


    Haven't tried it to check it works but let me know...

    K

  4. #4
    Automated Home Sr Member BodgeIT's Avatar
    Join Date
    Jul 2010
    Posts
    57

    Default

    ...strange, works for Joggler and Browser but not HAL.
    Is it possible to check versions? I should be running 5g, maybe that's the issue?

    One other small question...is it possible to create a link to another app on Joggler from xAPFlash? I was hoping to put in a button for the Squeezebox app I've installed...

  5. #5
    Moderator Kevin's Avatar
    Join Date
    Jan 2004
    Location
    West Yorkshire
    Posts
    554

    Default

    Sorry I don't know what HAL is ? If you mean HAH then it should work as it is the same build.

    Take a look through the HAH xAPFlash help and also you can look within the sample XML configuraton files that Brett supplies to see how his buttons were defined.

    Please do post back with what you find as I would like to know what is different.

    You can't include a button to link to another Joggler application so you will have to go via the two buttons - quitting xAPFlash and loading the SqueezeBox app

    K

  6. #6
    Automated Home Sr Member BodgeIT's Avatar
    Join Date
    Jul 2010
    Posts
    57

    Default All working

    obviously a caching thing. Came back to it the next day and all was working as expected on all platforms.

    Thanks Kevin.

    P.S. yeah HAL is my HAH
    Last edited by BodgeIT; 23rd January 2012 at 11:27 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •