can anyone help me with an issue, I have just bought a secondhand homevision controller.
I am using HVXL and can force commands to turn on X10 devices and the user LED on the front of the unit, so I know that I have a good connection to both the controller and to my X10 devices.
I have also learned my remote the homevision codes (device set 2 all 255 codes!!) and the controller recognises the codes.

If I set an action IR0 to a code i.e. device set 2 code 20; X10 F2 ON nothing happens, I can see on HVXL that it has recieved the signal and that it associates that signal with IR 0 but nothing happens.
The HVXL states Device set 2 Code 14 (14 hex =20) = IR0 Uplighters On

If I set a similar action i.e turn on user LED with device set 2 code 22 nothing happens.

I have also used X10 to trigger actions, dosen't work.

If I set a scheduled action i.e. X10 F2 ON at a specific time nothing happens,
same if I try to set the user led.

I have also tried to call a Macro from an IR signal device set 2 code 20, again nothing happens.

I have tried to set an action direct after download nothing happens!!

I have also set an action from an input i.e. if input is off do action also using the input to set a variable which then starts a macro, nothing happens!!!

I know that the schedules are downloading into the controller because I can check them fro HVXL.

I know that I have a good X10 connection because I can see actions sent from my remote to X10 devices displayed on HVXL and I can send commands direct from HV, no commands fail to X10 devices i.e. X10 F2 ON works.

It's as if the controller is not processing the event but will execute direct Commands, however if I check the unit from HVXL no errors are reported.

The only issue I get is that HVXL does not appear to be able to pull the time from the unit, OK that could explain why the scheduled event doesn't happen but nothing else.

If I pull the power the schedule is still in the memory after power up and the self test is OK.
I can check from HVXL what events are in the controller and they are there.

I'm a service engineer and program PLC's so I'm not inexperienced with control sytems but this has me stumped.

Maybe I have a mental block with this but as far as I can tell if I associate an action to an input IR, RF, Digital input or a time it should execute that command i.e. X10 F2 ON, I have also tried Force ON, BUT NOTHING HAPPENS!!!

Anyone else had a similar problem?