Results 1 to 3 of 3

Thread: Trigger macro on Stealth mode enable/disable

  1. #1
    Automated Home Sr Member eddr's Avatar
    Join Date
    Mar 2011
    Posts
    51

    Default Trigger macro on Stealth mode enable/disable

    Hello,

    As the title says - I'm trying to trigger a macro on Stealth mode state changes, but when selecting the macro object the only action listed is 'Busy'.

    What I'm trying to acheive is, whenever stealth mode is enabled, to run a macro which will turn a light off and on (Not flash, just turn it off then on - don't ask why!)

    Any ideas why it just says 'Busy' ?? - By the way, the macro is not running
    Last edited by eddr; 20th December 2011 at 10:01 PM. Reason: addition

  2. #2
    Automated Home Legend Karam's Avatar
    Join Date
    Mar 2005
    Posts
    826

    Default

    If you go to the All Light objects connections you should be able to connect the macro start to the stealth mode output state connection, however having tried this myself I find it seems to be work in inverse logic i.e when stealth off macro fires. Actually I was surprised that it didn't fire on both edges and that I'd have to do a conditional on state at entry .. something to investigate...

    Another option is to connect whatever is enabling stealth mode to also trigger the macro

  3. #3
    Automated Home Sr Member eddr's Avatar
    Join Date
    Mar 2011
    Posts
    51

    Default

    Excellent, that's a way round it atleast...

    Cheers Karam!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •