I would be grateful for some help. Just installed a modem (an old one which I had had lying around) to try the telephony features of Cortex, but have run into problems. Not sure if the modem itself is faulty or something not quite right elsewhere.

The rackmount PC running cortex sits in the garage Node 0, and is my only computer running windows (XP). I access it via my ubuntu box using RDP. RDP does have problems with sound, so I installed tightVNC.

In Cortex, under Telephone/Behaviour, on the "voice prompts" tab, everytime I click the "speech synthesis options" button, I get an empty error box. After clicking the OK button, I then get the "telephone speech configuration" dialog, where I have selected Microsoft Mary and my RealtekAC97 soundcard. I have tried both the voice message as well as wav file options, but no difference.

On the "configure" tab, I have set manual answer. Now, when I call my landline using my mobile, I get the expected "ringing" on "call state". When I press the "activate answer machine" button, Cortex answers the call, but there is no message or wav played out. I then hang up on my mobile. One of 2 things happens (random) when I re-call. Either the fax modem kicks in with its beeps and whistles, or the phone rings normally. When I now press the "activate answer machine" button, I get an Error dialog with the following messages: "Error: Line device is not active. Use the LineActive method to activate it". The answer state is left at "waiting connection".

My understanding is that the LineActive method is from Delphi? I presume for some reason the communication between Cortex and the voice modem is not reset after the first call? I have tried to reduce the speed down to 9600, and there is no fax device.

Sorry for the long post, but it is quite difficult to describe in words a series of events! I have listed the modem diagnostics below. Perhaps I am missing something obvious?

Thanks you.

The modem is a PCI modem (no name Intel 537 driver) running on COM4 (not sure why - COM1 is for my PCU and COM2 is marked as being used by XP).
Port speed 115200
Data protocol Standard EC
Compression enabled
Flow control Hardware
Hardware settings 8N1
Modem Info:
AT+GMM - Intel(R) 537 Modem
H.324 video-ready rev. 1.0
AT+FCLASS=? - 0,1,8
AT+GCI? - +GCI: B4
AT+GCI=? - +GCI: (B5,61,35,14,25,27,85,88,98,A9,BC,A5,31,3C,82,52,5 7,58,68,A0,AE,42,0A,A6,2D,46,59,69,7B,B4,0F,3D,8B, 84,00,B8,09,6C,26,50,9C,7E,07,16,73,E3,53,89,54,0B ,0E,12,49,4E,4F,5B,7F,87,8C,A3,AC,B7,BB,C4,4D,E0,5 1,E2,B3,FC,20,2B,33,37,41,45,8A,36,2E,9F,E1,1B,A1, FA,F8,F7)
ATI1 - Intel(R) 537 Modem
ATI2 - Intel Corporation
ATI3 - 537
ATI4 - 537 Release 4.54 - May 16 2003 - 19:25:31
ATI5 - CP Code Location: Host PC
DSP Code Location: Host PC
Host Interface: PCI
ATI6 - DSP Software Version :