Results 1 to 3 of 3

Thread: Changes to API in v26.7?

  1. #1
    Automated Home Sr Member
    Join Date
    Jul 2004
    Posts
    55

    Default Changes to API in v26.7?

    Hi guys,

    I've just upgraded to v26.7 and my little app which looks at the API to see if certain lights have been turned on can't seem to see anything happening when those lights are turned on/off.

    I've checked in Tools/API and a "ListObjects" command lists the objects I expect. When I turn the lights on and off nothing appears in the Tools/API log window (I'm presuming it should).

    I can see the Pulse and NetworkRunningState in both my app and the Tools/API log window.

    Has something else changed which I haven't spotted?

    Thanks,

    Peter.

  2. #2
    Automated Home Ninja Viv's Avatar
    Join Date
    Dec 2004
    Posts
    284

    Default

    Quote Originally Posted by pbj View Post
    Hi guys,

    I've just upgraded to v26.7 and my little app which looks at the API to see if certain lights have been turned on can't seem to see anything happening when those lights are turned on/off.
    ...
    Peter.
    It was a bug introduced. A speed improvement was added to the communication between objects (albeit micro seconds) which has resulted in some output states not being reported to the API. Update version 26.7.2 should resolve this.

    Viv

  3. #3
    Automated Home Sr Member
    Join Date
    Jul 2004
    Posts
    55

    Default

    Thanks Viv - all fixed.


    Peter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •