Thanks to the support on this forum, and of course from Karam, I now have my Idratek system up and running!

I'm using a Samsung NC10 running Windows 7, and powered up the network today.
I have a PLH-001 in the kitchen, which also links to a door contact on the kitchen door. A THS-001 monitors temperature and humidity in the utility room (that will one day operate the extractor fan!). I have enough cable around the house now to add further modules, mostly for lighting and heating, and then also things like the doorbell.

I encountered four problems today. If anyone can point me in the right direction, I'd be grateful.

I do have an old DFP (bought 2nd hand), which I plugged into the network. I have the sound set up. I can send a 'bong' when the kitchen door opens, but it won't read any speech. I have speech enabled in the same properties window. I installed 'Mary' and turned up the speech volume in the speech engine window. I just can't get any speech.

My second problem concerns a (2nd hand) DRB-002. I connected it up to my kitchen lights (2 circuits, both LED). I configured it so that each button controlled one circuit, toggled on/off. It worked a couple of times, then one of the circuits stayed on, whether or not the module was on or off. I tried resetting the unit, controlling it from Cortex, rebooting, cutting the power, etc. but I just couldn't turn it off. Does it sound like it's broken?!

Thirdly, this same DRB-002 has the same ID as the PLH-001. When I 'read' the node in Cortex, it lists all the features of both units together. I guess it was already commissioned with the same ID, and the order in which I installed the units created the problem. I tried changing the ID, and following instructions in other threads, but when I plug it back in, the issue is still there.

As both of these issues relate to the same unit, the answer might be to scrap that one?

Finally, when I try and access Cortex via a web browser (either locally or on another machine, including iPad), after logging in, I get the error 'XSL XML HTM Transform error'. Any ideas? A search doesn't throw any light on this.

Many thanks in advance. I'm looking forward to expanding my Idratek - I've got so many ideas!

Alex