I've plugged my old Current Cost back in to my raspberry pi after a long time in the cupboard and I can't get the serial port to work. I've tried both 2400 & 9600 baud (it's a Classic Current Cost rather than one of the newer ones).

If I had the wrong baud rate I'd at least expect to see gibberish, but I'm even getting that.

The port shows up when I look for attached USB devices

pi@raspberrypi ~ $ lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 007: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

and I've added the usbserial kernel modules:

pi@raspberrypi ~ $ lsmod
Module Size Used by
pl2303 8482 0
usbserial 26929 1 pl2303

and tried to watch what comes from the port using screen as a serial terminal and that's where I get nothing.