Results 1 to 3 of 3

Thread: Disable Macro oddness

  1. #1
    Automated Home Sr Member
    Join Date
    Jul 2004
    Posts
    56

    Default Disable Macro oddness

    Hi all,

    I'm having some difficulty with a "disable macro" connection. I have a connection from a "going bright" output of a light level sensor to disable a macro. This has been working fine, but now doesn't seem to do anything.

    I've tried starting a dummy macro with the going bright output and that works fine and I've also tried disabling a macro from another macro and that's fine. I can of course introduce a dummy macro, but that seems to be a bit messy. I'm not sure but it might have been around the time of the last update, have I missed something?

    Peter

  2. #2
    Automated Home Ninja Viv's Avatar
    Join Date
    Dec 2004
    Posts
    284

    Default

    The behaviour of the macro Disable and Enable inputs was changed in update 26.10.4.

    As stated in the summary...

    "Macro Object
    Enable and Disable inputs now require
    Sender to be 'True' to action.
    "

    What this means is when an object triggers its output and sends a message to the Macro the Sender needs to be 'True' on that connection.

    However the Light Level on going bright simply triggers its output but does not assert a true state for having gone bright. This can be considered a bug and will be fixed in next update.

    Their is a work around.
    In the Light Level object create a User Defined Threshold with Name say 'My Bright threshold'. Set the threshold to a suitable level. In The State output connection for the threshold connect that to the Macro Enable input. This should do what is required.

    Viv

  3. #3
    Automated Home Sr Member
    Join Date
    Jul 2004
    Posts
    56

    Default

    Thanks for the speedy reply Viv.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •