Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: SmartThings + Raspberry Pi & Homebridge = Siri HomeKit Controlled Smart Home

  1. #11
    Automated Home Ninja Mavis's Avatar
    Join Date
    Oct 2014
    North East


    Yey I have done it!

    That was some marathon project. Mainly because I didn't have a scooby do. I asked for help on the SmartThings forum but in the end I worked it out for myself.

    The problem was the config.json file - I had only created the file with the text and access key from the SmartThings app. What I did was open the config-sample.json file (which is an example to show what format the config.json file should be.) and use this code which has the homebridge username and key as a template to then paste in the code from the SmartThings app. Once I did this then homebridge ran properly and it generated the code to put into the Eve App.

    I did have a problem as I have 2 sonos in the living room both called the same so I just deselected one and reran homebridge. It then worked ok. As the 2 sonos were grouped, when I select the one to play through Siri both do work in stereo.

    I am having issues in that Eve sometimes shows things as being unavailable even though my Pi is on and homebridge is running. I have restarted the Pi and my phone but it still does it. However in the few hours I have been playing with Siri, it does appear to work once I have worked out the best phrases to use. Sometimes Siri says he is thinking about things but it still works without him saying it has.

    I also installed idevices a few weeks back (after seeing the article about it on here) but hadn't used it as I didn't have any compatible devices but that now works.

    I need to spend some more time seeing how I can use it and what else I can add to it - for instance I am now wondering if I can add my lightwaverf stuff to it. If so then it would be cool.

    So now I think I will reward myself with a very large glass of wine.

  2. #12
    Automated Home Lurker
    Join Date
    Mar 2016

    Default Almost!

    Hey! Thanks so much for this walkthrough. I'm super excited to get this working, but I ran into an issue. At step 6, where you're supposed to click select Config in the Smart Things app, I got this message "{"error":true,"type":"AccessDenied","message":"Th is request is not authorized by the specified access token"}"

    Any ideas?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts