Help! My SmartThings app has stopped letting me save bulbs being added in. Have had no problem until recently. A couple of weeks ago I added the Philips Gue Go; no problem all was accepted and works. A few days ago I tried to add the Philips Hue Beyond light. The app saw it as two, which it should as there is an up and a down, but when I went to save it I got the message "Failed to save page: bulbDiscovery".

Philips's own Hue app and other Hue apps see it and operate it with no problem.

I have deleted the SmartThings app and reinstalled. It made no difference.

I then deleted all reference to both the Hue Go and Hue Beyond everywhere so that they don't exist. I then tried to add back first the Hue Go in the SmartThings app and got the same message. The app was happy with it before so assume it cannot be compatibility with the Go. Even if I tell the app to ignore the Go and Beyond lights and just select an existing Hue bulb it won't save but gives me the same message.

I have been in touch with support but they cannot help. There appears to be something defective in the app.

Anybody any ideas?