Results 1 to 7 of 7

Thread: Desperately seeking Evohome installer in Herts/North London

  1. #1
    Automated Home Jr Member
    Join Date
    May 2016
    Posts
    14

    Default Desperately seeking Evohome installer in Herts/North London

    I have a relatively complex system so don't want to do wiring myself, sure I could do install once wired. Its made up of 3 zones: Underfloor which splits into three sub-zones, rest of house radiators & Hot Water.
    I've now had four installers visit. One was excellent knew his stuff quoted about 300 on top of kit for install which seemed realistic although despite promising to get it done by end of Feb at latest, i'm still chasing him. He obviously knew his stuff bur totally unreliable, happy to share his name for those interested in never getting an install in the Herts area! Another quoted 750 for install (pi** taker) and wanted to change boiler and underfloor manifold! The other two didn't even bother quoting.
    If anyone can recommend I'd be really grateful....

    Thanks

  2. #2
    Site Sponsor The EVOHOME Shop's Avatar
    Join Date
    Dec 2014
    Location
    Powys, Mid Wales
    Posts
    482

    Default

    Who were these people? I have a few guys we recommend in North London area, but would be good to know who you have tried first. You can PM me if you wish.

  3. #3
    Automated Home Legend top brake's Avatar
    Join Date
    Feb 2015
    Location
    the edge of the cloud
    Posts
    837

    Default

    Hi David Please pm me to discuss thanks

  4. #4
    Automated Home Lurker
    Join Date
    Jan 2015
    Posts
    8

    Default

    Hi

    I've had someone come over and fit my kit, but has turned into a bit of a nightmare... Had it working first time only to find out after he had gone that the heating would come on when the hot water came on. Came out today to fix the issue and unbound the relays as it was double bounded . But now the whole system won't work and as he could get anything to bind properly... And has said I would need a new controller as I have one of the original ones ..... Does this sound normal? And is there an installer you might know that is east London / Es*** that could help me ??

  5. #5
    Automated Home Lurker
    Join Date
    Sep 2015
    Posts
    7

    Default

    Mine was installed by Anthony at South East Gas Ltd. He's very reasonable and has been back a couple time for other bits and pieces. Give him a buzz to see if he'll cover your area. He certain covers N16.

    http://www.southeastgas.co.uk/

  6. #6
    Automated Home Guru
    Join Date
    Feb 2016
    Posts
    244

    Default

    And has said I would need a new controller as I have one of the original ones ..... Does this sound normal?
    There have been a few updates to the menus in the new controller to both fix some problems and drop some functionality and it also has in-built wifi so the separate gateway is no longer required for control over the internet, but I don't think it's essential to upgrade to a new controller (I assume that you have the colour touchscreen one which requires a separate gateway device). If there's a fault with your controller then that's a different issue, but they should be able to set-up a functioning system with your controller. If you'd like any help with trying to configure or troubleshoot the set-up yourself, if you post your system details (list of Evohome devices) and the Central Heating and DHW set-up we can try and provide some additional advice. I've read your previous posts about the difficulties with the DHW set-up, but it didn't seem to be too complex an installation.

    Dan

  7. #7
    Automated Home Lurker
    Join Date
    Jan 2015
    Posts
    8

    Default

    Quote Originally Posted by DanD View Post
    There have been a few updates to the menus in the new controller to both fix some problems and drop some functionality and it also has in-built wifi so the separate gateway is no longer required for control over the internet, but I don't think it's essential to upgrade to a new controller (I assume that you have the colour touchscreen one which requires a separate gateway device). If there's a fault with your controller then that's a different issue, but they should be able to set-up a functioning system with your controller. If you'd like any help with trying to configure or troubleshoot the set-up yourself, if you post your system details (list of Evohome devices) and the Central Heating and DHW set-up we can try and provide some additional advice. I've read your previous posts about the difficulties with the DHW set-up, but it didn't seem to be too complex an installation.

    Dan
    Hi, managed to speak to richard at the evo shop who advised when binding on the old controller to wait 5 minutes once the success appears on the screen before pressing the tick to move on, so after unbinding the relays and then rebinding and waiting 5 minutes between each one it all is working. Thanks DanD for the offer, im sure at some point i will need help again... with regards to the difficulties with the DHW, ended up using the secondary return (i think thats what it was) and reversed a pipe into the cylinder and used that as the well to place the probe for the reading of the hot water.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •