Results 1 to 3 of 3

Thread: RDP and loss of sound windows 8.1

  1. #1
    Automated Home Jr Member
    Join Date
    Mar 2010
    Location
    Nelson, New Zealand
    Posts
    26

    Default RDP and loss of sound windows 8.1

    I previously used a batchfile with the tscon.exe command posted by Gumby to disconnect my RDP sessions from cortex, otherwise there was a complete loss of sound as the RDP session was not disconnected properly.

    This does not seem to work with windows 8.1 (just belatedly upgraded from XP due to death of old PC). With a bit of googling, it appears that microsoft now increment the RDP session number with each login.

    So my new batch file contains

    for /l %%x in (0, 1, 100) do tscon.exe %%x /dest:console


    this gives a series of tscon commands with session numbers from 0-100 and this seems to disconnect the RDP session and reconnect the sound properly. This needs to be saved as a .bat file somewhere not on the desktop, then rightclick, send shortcut to desktop. Go into the shortcut properties, select shortcut, advanced and check run as administrator.

    Now double click on this shortcut to finish your RDP session and sound will work from cortex.

  2. #2
    Automated Home Legend chris_j_hunter's Avatar
    Join Date
    Dec 2007
    Location
    North Lancashire
    Posts
    1,670

    Default

    not sure I follow - but TeamViewer works for us ... !

  3. #3
    Automated Home Jr Member
    Join Date
    Jan 2013
    Location
    Thassos, Greece
    Posts
    32

    Default

    An alternative might perhaps be to connect through RDP without taking over the sound (i.e. leaving the sound to be played on the remote computer). This way all messages sent by cortex while you are connected through RDP would still reach their intended destinations.

    /Glenn

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •