Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Batteries not charging on evohome - solution

  1. #11
    Automated Home Guru
    Join Date
    Jan 2016
    Location
    Hampshire, Great Britain
    Posts
    100

    Default

    Rameses wrote:-

    For existing install
    1) With the evohome powered on the dock/wall plate
    2) Remove face plate and remove batteries and wait until the battery symbol with an X appears top right (should appear after >5 seconds)
    3) Re-install batteries and face place
    4) Battery symbol should now show the charging flash
    5) Leave the unit on the charging cradle until the battery is fully charged and the symbol will disappear

    This should allow the evohome to fully analyse the battery status properly and engage the charging cycle and then once fully charged allow operation for 3-4 hours off mains power when required.
    Firstly thank-you for this suggestion...

    Do you have any idea of how long it should take to fully charge the batteries please? The controller has been showing the "charging" indication for over 8 hours now.

    Second question... somewhat Obessesive Complusive but I am contemplating replacing the batteries, can you recommend the best replacement?

    FB
    Last edited by FullBore; 20th December 2016 at 05:52 PM. Reason: To clarify.

  2. #12
    Automated Home Sr Member
    Join Date
    Apr 2016
    Posts
    61

    Default

    ally153 - I have bumped this old thread as it covers the battery charging problem that can affect the controller from time to time and gives the work around for those who are not familiar. I have never found any problem with the contact resistance, possibly because the batteries fit so tightly they are very, very difficult to remove (I have tried several brands but they are all a tight fit). Regularly letting the batteries run down helps but the controller gives irritating beeps soon after removing from the wall until the batteries finally run down.

  3. #13
    Site Sponsor The EVOHOME Shop's Avatar
    Join Date
    Dec 2014
    Location
    Powys, Mid Wales
    Posts
    482

    Default

    Blimey... Hi everyone! Long time no speak...

  4. #14
    Automated Home Sr Member
    Join Date
    Apr 2016
    Posts
    61

    Default

    Welcom back, your input is always helpful, and sadly in this case stil valid.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •