Results 1 to 5 of 5

Thread: Evohome zone problem.

  1. #1
    Automated Home Lurker
    Join Date
    Apr 2018
    Posts
    5

    Default Evohome zone problem.

    Hmmm, can't figure this one out.

    I have a zone on the top floor of my house with 4 actuators however which simply won't kick their radiators into life. The radiators all work fine with TRVs on and the actuators all work when put on other radiators but they will not switch the radiators on and off on the top floor. I wondered whether it might be because they aren't picking up the signal from the controller but they do seem to change when I change the temperature settings, they just don't open up as required.

    I've changed all the batteries, deleted the zone and recreated it and tried with just one actuator, all without any joy.

    Any ideas or thoughts very welcome!

  2. #2
    Automated Home Jr Member
    Join Date
    Aug 2018
    Posts
    29

    Default

    Are they mounted cleanly with the locking lever in place? Also are the valve bodies the same as are in zones which respond properly?

  3. #3
    Automated Home Lurker
    Join Date
    Apr 2018
    Posts
    5

    Default

    Hi BuxtonJim. Many thanks - yes, I tightened all 4 and made sure they fitted on properly and latched on. Not sure what you mean about the "valve bodies" - the actuators all fit on in the same way as those in zones which work correctly.

  4. #4
    Automated Home Jr Member
    Join Date
    Aug 2018
    Posts
    29

    Default

    Hi Evo -user. I wondered whether for some reason your top floor TRVs were a different model from others you have and perhaps needed adaptors. By valve body I meant what's left on the radiator when you take the actuator off the top.

  5. #5
    Automated Home Lurker
    Join Date
    Apr 2018
    Posts
    5

    Default

    I'm with you. Actually one of them did need an adapter but the other three all fit on in the same way so I don't think it's that. When they were installed all the zones worked no problem but at some point the top floor became an issue. Not sure that helps!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •