Page 16 of 16 FirstFirst ... 6111213141516
Results 151 to 153 of 153

Thread: My HGI80 equivalent Domoticz setup without HGI80

  1. #151
    Automated Home Jr Member
    Join Date
    Feb 2018
    Posts
    19

    Default

    Hi @dty

    I haven't been able to get "sending" working with your firmware running on an arduino nano (using @petep's nano files). Receiving works absolutely fine. I've tried various baud rates from 78600 all the way to 250000, but still nothing on the send. As soon as I install @petep's fifo branch, sending works immediately.

    However, pete's fifo branch does not seem to receive anything from my HCC80 ufh controller, whereas your firmware immediately receives heat demand data from the HCC80 (including the different zones being controlled by the HCC80).

    Do you have any suggestions of things I could try to get sending working with your firmware? Unfortunately I don't know enough about how the radio system works to make a guess as to what to tweak etc.

    TIA.

  2. #152
    Automated Home Jr Member
    Join Date
    Apr 2006
    Posts
    22

    Default

    Doing some research could it be that level shifting is required between the 5v Nano and the 3.3v CC1101 ? have a look at this diagram on Simon Monks github https://github.com/simonmonk/CC1101_arduino

    some folks saying its necessary which I could see being an issue

  3. #153
    Automated Home Jr Member
    Join Date
    Feb 2018
    Posts
    19

    Default

    Thanks for the headsup on this. I'll look into it further when I get a bit more time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •