Results 1 to 3 of 3

Thread: Y87RF2024 LCD Display partially failed

  1. #1
    Automated Home Jr Member
    Join Date
    Jan 2016
    Posts
    15

    Default Y87RF2024 LCD Display partially failed

    Hi,
    I have had one of my Thermostats around half of the segments on the LCD panel fail (The second temperature digit and all symbols). It seems a loose connection as light pressure on the case makes them return, and the unit works as expected. Anyone else has a similar issue. Unfortunately out of Warranty, but from a fitness for purpose perspective I would expect on of these to last more than 18 months (especially as I have 10 of them). I will see what Honeywell say, but interested if this has happened to anyone else.
    Thanks,
    Neil

  2. #2
    Automated Home Ninja
    Join Date
    Aug 2016
    Posts
    489

    Default

    Have you checked the batteries and connections? It could be that the terminals would benefit from being bent outward slightly to make a better connection with the batteries.

  3. #3
    Automated Home Jr Member
    Join Date
    Jan 2016
    Posts
    15

    Default

    Thanks dty, it wasn't actually the battery connections, but in following your advice I noticed the pcb was not quite seated properly. It was a really marginal amount but it did the trick and I would have sworn a failing LCD. Credit to Honeywell support as well for a fast response and a willingness to investigate.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •