Results 1 to 8 of 8

Thread: Comms faults re-occuring after exactly 3 hrs 10 mins

  1. #1
    Automated Home Sr Member
    Join Date
    Jan 2015
    Posts
    78

    Default Comms faults re-occuring after exactly 3 hrs 10 mins

    Once again I have found the BRD91 activated when there was no heat demand programmed for any of the valves.

    On looking in the Fault Log I discovered an interesting sequence of events:

    There was a Comms Failure reported on zone 4b which was restored after 6 days(!). After a further 3 hours and 10 minutes it failed again for another 5 days.

    This pattern of restoring and then failing after exactly 3 hrs 10 mins was repeated twice more.

    Tests on the comms link to this particular zone show a signal strength of mostly 3, occasionally 2, never 1 or less.

    So my question is: what is the significance of the period of 3 hrs 10mins?? Has anyone else seen this phenomenon? What can be done to stop it recurring?

    The problem of unexplained boiler firing has now been occurring from time to time for nearly 3 years, see my post at http://www.automatedhome.co.uk/vbull...and-from-BRD91 and the subsequent discussion at http://www.automatedhome.co.uk/vbull...ding-corrupted; it was logged by Honeywell in 2015 but I have never heard anything further.

    Until I find a solution to this unexplained behaviour we dare not go away leaving the system under the control of Evohome in case we come back to an empty oil tank!

  2. #2
    Automated Home Legend
    Join Date
    Sep 2014
    Location
    Scotland
    Posts
    2,129

    Default

    Just over three hours is how long the controller will tolerate the absence of a regular "check in" from a device like a hot water sensor or BDR91 before it logs a fault.

    For example the hot water sensor will only report in as infrequently as once an hour if the temperature is cold (hot water off and cooled down) and the temperature is not changing, so clearly it can't report a fault for that if it has only been missing for an hour. 3 hours and 10 minutes would allow 3 missed transmissions before assuming something is wrong to avoid false positives from one transmission that was lost due to for example a transmission collision or temporary interference.

    Messages occasionally go missing during normal operation due to random collisions or interference from other devices, you wouldn't want the system to notify every time a single message goes missing if its non critical so it waits a while to see if the problem persists.

    Almost certainly you do have a comms issue of some sort - this system seems to be really sensitive to nearby metallic objects I'm afraid, especially BDR91 and CS92A in my experience, but HR92's can suffer too. Two examples from my own recent experience:

    1) My BDR91's (3 of them) are on the inside wall of the boiler closet which is a light fire brick enclosure which backs up against the kitchen, which has a plastered wall. Not far from the other side of the wall from the BDR91 is a fridge, however this doesn't seem to cause me any problems and is not directly between the BDR91 and the controller. A couple of days ago I moved a small portable dehumidifier to sit in front of the fridge by the wall opposite where the BDR91 is to move it out of the way for a bit, a few hours later I noticed a comms failure to my "heating relay" in big red writing on the controller. Whoops.... I've never had a fault to that BDR91 before but it was indeed the lowest mounted one giving the issue (they are stacked vertically) and it was at about the same height as the top of dehumidifier. I moved the dehumidifier and did a quick comms test - which passed 5/5 and the fault self cleared and hasn't reoccurred. The BDR91 was only 6 metres from the controller.

    2) In my study I have a typical swivelling computer chair with 5 wheels and a steel shaft from the seat to the wheels. It's relatively close to the end of a long radiator and unfortunately the HR92 is on that end of the radiator as that is the return side. One day I had lost comms with that HR92 and when I went to investigate I noticed the chair had been pushed quite close to the corner of the radiator - maybe a foot away so the vertical steel shaft of the chair was about 2 feet from the HR92 and roughly in line between it and the controller - resulting in lost comms. I moved the chair maybe 2 feet back to where it normally should be and comms was restored. This HR92 is less than 6 metres from the controller through a single wall.

    So yes, the system is VERY sensitive to metal objects near any of the devices, and it is quite unpredictable whether a given object will cause a problem or not. If I put my engineering hat on I would say that the root cause is probably multipath reflections from the metal object causing signal cancellation - if so, the relative positioning of the device and the object would be very critical - moving it just a few inches one way or another could solve the issue.

    Unfortunately signal tests don't seem to reveal the problem, probably because you standing in the vicinity doing the test provides another reflection path that avoids complete cancellation.

    It might be worth you describing the physical layout of the devices and the metal objects nearby even if they don't seem significant.
    Last edited by DBMandrake; 28th August 2017 at 03:44 PM.

  3. #3
    Automated Home Sr Member
    Join Date
    Jan 2015
    Posts
    78

    Default

    Quote Originally Posted by DBMandrake View Post
    Just over three hours is how long the controller will tolerate the absence of a regular "check in" from a device like a hot water sensor or BDR91 before it logs a fault....

    So yes, the system is VERY sensitive to metal objects near any of the devices, and it is quite unpredictable whether a given object will cause a problem or not....

    It might be worth you describing the physical layout of the devices and the metal objects nearby even if they don't seem significant.
    Thanks for that, very helpful. From your explanation it sounds as though poor comms to this one zone is the usual state of affairs, however once every few days the HR80 gets a msge through but then silence prevails again. Using the procedure in the HR80 instruction leaflet the link seems OK from the controller to the HR80, is there a way of testing in the other direction? This valve is the furthest away from the controller, however there are no metal objects in the vicinity apart from a steel radiator and lots of copper pipework which I would have hoped it could cope with(!)

    Fortunately the link from the controller to the BDR91 seems better (5/5 with the controller one floor directly below it and 3/5 at the other end of the house). Though I have had my suspicions of the BDR91 in the past and it is the only part of the original system that hasn't been replaced under warranty.

    It seems that Heat Genius have chosen a much more robust solution by using Lightwave, with repeater capability in every mains-powered unit and available as add-ons. I am surprised that Honeywell haven't responded with their own repeater. But I seem to remember another thread about why it isn't possible using their proprietary comms protocol (not a good system design choice IMHO).

  4. #4
    Automated Home Legend
    Join Date
    Jan 2015
    Location
    NE UK
    Posts
    1,156

    Default

    I endorse DBMandrake’s advice. Do check the distance between devices and metallic objects. Follow the recommendations of a minimum separation of 30cms and even that may be still too close sometimes. I had issues in the beginning like this until I ensured my BDR91s were separated.

    I occasionally get the odd fault report saying contact has been lost but it gets restored again a couple of hours later and never an issue. Always with my domestic hot water when it says it loses contact with the sensor. I ignore for it all works. The sensor is a little closer to my tank than I would prefer and have thought it may be that. It does not often happen. I can live with it and do so knowing my boiler is on borrowed time now so there is a change ahead anyway.

  5. #5
    Automated Home Legend
    Join Date
    Sep 2014
    Location
    Scotland
    Posts
    2,129

    Default

    Quote Originally Posted by G4RHL View Post
    I endorse DBMandrake’s advice. Do check the distance between devices and metallic objects. Follow the recommendations of a minimum separation of 30cms and even that may be still too close sometimes. I had issues in the beginning like this until I ensured my BDR91s were separated.

    I occasionally get the odd fault report saying contact has been lost but it gets restored again a couple of hours later and never an issue. Always with my domestic hot water when it says it loses contact with the sensor. I ignore for it all works. The sensor is a little closer to my tank than I would prefer and have thought it may be that. It does not often happen. I can live with it and do so knowing my boiler is on borrowed time now so there is a change ahead anyway.
    If the real issue is that metal objects are causing reflections that are summing destructively to cause a near null in the signal (which I'm sure you will know all about given your handle ) then moving the device in question a relatively small almost insignificant distance could make all the difference between it being unreliable and reliable.

    Ramses 2 used by Evohome works at 868Mhz, where half a wavelength is 17.2cm, depending on which angle a destructive reflection is coming from, moving it as little as 5-10 cm could be enough to move it out of a null if you get lucky and move it the right way.

    The power levels are so low on these devices that they can't afford to be sitting in a reflection induced null, and unfortunately the signal test option is mostly useless for figuring out whether there is a reflection null at one end of the link or the other, because as soon as you stand near either end of the link (by the controller, or by the sensor/actuator) to perform the test your body provides yet another reflection or absorption path that could upset the critical balance of a null - the very act of you standing there causes the signal null that you are trying to test for to go away!

    But when you leave the area the balance forming a null will return and so will the problem. Likewise the moving of metallic objects in the house in the vicinity of devices that are not always in the same location may cause a problem to come and go - just like it did when I moved a dehumidifier into position near a BDR91 even though there is a gigantic fridge right next to there that wasn't causing an issue prior to that.

    So my best piece of advice is unfortunately trial and error, as the system does not provide any real way to troubleshoot this. First confirm that the signal level in general on a test is OK (at least 3/5) and then move the device (CS92A/BDR91 - you can't really do this with an HR92) say 5-20 cm to a different location. If necessary try a few different locations and give it a day or so to see if an intermittent comms fault returns or not. I moved my CS92A twice back when I was trying to solve very random hot water overshoots, (which will have been intermittent comms) and the second time I only moved it 10cm and it made quite a difference.

    This is probably particularly the case with a CS92A because it is inevitably not that far from a huge metal hot water cylinder. Unless you extend the sensor cable it is pretty much inevitable that it is going to be uncomfortably close to the cylinder...
    Last edited by DBMandrake; 30th August 2017 at 01:06 PM.

  6. #6
    Automated Home Legend
    Join Date
    Jan 2015
    Location
    NE UK
    Posts
    1,156

    Default

    Aye, I suppose my handle speaks volumes!⚡️

    We are fortunate they are low power devices but as you say even then radio waves are never so straight forward and their length, multiples or divisions thereof can create issues. It took me ages to solve a problem in my garage. Not Evohome gear but a wireless remote control door panel being intensely disliked by a wirelessly controlled light relay. About 7 feet away did the trick. Then there are the solar panels on my neighbour’s roof. When they are powered up I get a signal coming in on a 2m frequency. In my previous house some 25 years ago my neighbour opposite installed a wonderful remote control garage door. He was puzzled to see it open and close on its own. A transmission on 10m would do the trick! I did tell him, by the way!

    In the case of my DHW Sensor the relay is just on the wrong side of 30cms from the sensor strapped to the tank. And yes, I have come across instances of electric white goods causing issues and in the early days of transistor radios the human body could be a great source of enhanced signal strength and sometimes degradation. So anybody new to this sort of gear and getting errors, don’t immediately blame the gear, they could so easily be signal errors caused by interference. The proximity of other devices, and the amount we have in the house is ever growing.

  7. #7
    Automated Home Sr Member
    Join Date
    Jan 2015
    Posts
    78

    Default

    Well I am afraid after 40 years as a chartered EE I do blame the gear, because Honeywell could have chosen a more robust signalling protocol, could have designed a system capable of using repeaters to cope with difficult propagation conditions, and could with little extra effort have put better diagnostics in the controller so it would (a) show the incoming signal strength and/or message history for each device (b) ping specific devices on request (even if you have to wait for the reply) and (c) show which device/zone is calling for heat - as requested by many users here over the last 4 years.

    Also the fallback option in the valves, which is to default to a setting of 20 deg and eventually to stop attempting to communicate more than once every 24 hours, makes recovery from temporary comms failure un-necessarily protracted.

    I have now changed the offending HR80 for a different one and will see how that performs over the next two weeks.

  8. #8
    Automated Home Jr Member
    Join Date
    Nov 2012
    Posts
    10

    Default

    Quote Originally Posted by sharpener View Post
    It seems that Heat Genius have chosen a much more robust solution by using Lightwave, with repeater capability in every mains-powered unit and available as add-ons. I am surprised that Honeywell haven't responded with their own repeater. But I seem to remember another thread about why it isn't possible using their proprietary comms protocol (not a good system design choice IMHO).
    Heat Genius uses Z-wave which is a mesh system. It has worked faultlessly for two years with no hiccups.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •