This is my final Evohome commissioning issue. Everything else is working really well.

I have one room which has three identical radiators, and three HR92s. I have one of the HR92s set as the temperature sensor and all three bound as actuators.

Try as I might, whenever the circuit is hot, one of the radiators heats up (incorrect) while the other two remain cold (correct). I have tried deleting the zone and rebinding a number of times without luck.

I thought I had solved it this evening when I noticed that the misbehaving TRV head was unlocked, so following the manual I:
- Removed the head
- Turned the black wheel anti-clockwise until is stopped
- Replaced the head
- Locked it, shortly after which it CYCLed

With this done, I deleted the zone, waited a while for all TRVs to clear and then recreated the zone.

At zone creation, I bound one radiator as the sensor, then pressed green tick to add more, put the other two into binding mode and then press bind on the controller. The screen said 3 actuators bound 2 way.

Unfortunately, the radiator is still hot when it shouldn't be.

The other observation with that radiators is that pressing the button for 5s to enter the menu doesn't result in the menu being show, the head shows 'Binding' instead.

Please help!