Results 1 to 3 of 3

Thread: Radiators on hot water circuit

  1. #1
    Automated Home Sr Member
    Join Date
    Aug 2017
    Posts
    68

    Default Radiators on hot water circuit

    All my bathroom and toilet radiators (5) are on the hot water circuit. Is it possible to configure the evohome so that it 'calls for heat' on the hot water circuit (which will have the hot water kit on it) to get them to temperature or is it better to leave them on standard TRVs as they are now?

    [Edit]: Looks like they are on both circuits (I had noticed they heated up when the hot water was on, but not put it together with the heating!). So sounds like I just treat them as a normal multi-room zone.
    Last edited by Jabes; 27th March 2018 at 12:43 PM.

  2. #2
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,253

    Default

    If they are heating up on both HW and CH, it means that they are on the main heating loop before any zone valves. Before you go about putting TRVs on them, just check that they are not also playing the role of a bypass radiator.

  3. #3
    Automated Home Sr Member
    Join Date
    Aug 2017
    Posts
    68

    Default

    Quote Originally Posted by bruce_miranda View Post
    If they are heating up on both HW and CH, it means that they are on the main heating loop before any zone valves. Before you go about putting TRVs on them, just check that they are not also playing the role of a bypass radiator.
    Thanks Bruce - these radiators already have TRVs on them. I'll probably just leave these ones as they are to be honest...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •