Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: EvoHome Hot Water Kit >> Megaflow CL210

  1. #11
    Automated Home Jr Member
    Join Date
    Dec 2017


    Quote Originally Posted by omdaddi View Post
    How would I do this?

    Thanks for taking the time to help me out.

    (I am slowly working this out. Once I put the hot water relay in I realised I had made the (common) error of setting up the zone valves as boiler control. I have just set them up (I have three zones) by binding them at the same time when setting up the guided configuration. I worked out that there is < 10 litres in each circuit with all the TRVs closed downso am not going to worry too much.

    All a bit of an adventure really, though not sure it is going to save money. The kids are delighted they can crank up the temperature in their rooms!
    Someone more experienced than me will be able to tell you for sure, but my understanding is the Megaflo temp stat has an overheat stat built into it (effectively wired in series). It has a reset button on the front if it activates. So, in theory, as long as the stat is wired in series between your BDR91 and your motorised valve, the valve should close when the stat (or the overheat stat) open.

    This is a very important safety feature and actually illegal to work on if you're not G3 qualified. This is not to scare you, but rather to make apparent to you that if you do insist on DIY, make sure you are 110% confident in what you are doing.

  2. #12
    Automated Home Lurker
    Join Date
    Nov 2018


    I hear you. I have not done this lightly. In addition to my air con engineer friend, I figured that there were three wires I could have bridged, two would have worked, so I am 66% to start with. Then when I chose wrong, the water was clearly not working (the evoHome was not shutting off the heating, and the boiler was happily keeping the water at 68 degrees), I knew there was something wrong so I just unbound the BDR91 and left it on, and the circuit was back to before my fiddling.

    Last night I read the post by mtmcgavock and realised my error with the orange wire. I immediately fixed it and the system immediately started working as expected. So I am 99.9% sure I am OK.

    Today I looked at the control panel of the MegaFlow. It was awkward, facing away from me to around the left hand side of the cylinder with three pipes in front of it. Changing the temperature up was trivial (a dial as expected) but I could not see a pocket for the sensor. I figured that the control body was held in by the two screws either side of the cut out, and pretty much had to unscrew them with my fingers as there was barely enough room for the screwdriver to loosen them, plus the screws would be gone forever if I dropped them.

    I very carefully moved the control body out, but since I couldn't see in very well I couldn't see the pocket for the probe as described by mtmcgavock at all. I persevered and could just see two black wires disappearing, which must have been the MegaFlow stat leads. I fetched a mirror and bingo - I could see a rectangular pocket in the bottom right hand corner of the cut-out - exactly where it was impossible for me to see without the mirror. I gently pushed the black leads aside and carefully pushed in the evoHome probe. If I had had full access I am confident I would not have needed to take out the control body. Putting the screws back in was exciting, but I managed no drops. I returned the immersion heater to its original position and now everything is working perfectly.

    (I did have a little worry when the water was 48 degrees and no heating came on, but I worked out the hot water settings in the setup menu (System Devices > Stored Hot Water. The Stored Water Differential was 10 degrees and I had set the water to 57 to keep it below what I thought was the max on the MegaFlow before I went in to the MegaFlow panel to tweak up its stat.) It is now at 58 degrees. I am not worrying too much about Legionella. It was set at 58 degrees for the last 20 years.

    As I type, the water has heated from 48 to 57 over the last hour or so, and I am resisting the urge to stand by the relay to watch it go off at 58 degrees. That is the last test.

    Hope this helps someone.

    Later: Well, it went off, but I never saw 58 on the display. I guess it was there for a very short time and is now slowly cooling down towards the differential.
    Last edited by omdaddi; 14th November 2018 at 02:30 PM. Reason: Update

  3. #13
    Automated Home Ninja
    Join Date
    Mar 2017


    What I usually do is set the cylinder temperature control on maximum. On the MegaFlos this is 70oc where as others are usually 65oc. I then set the EvoHome to a more desirable temperature (55oc) and let the Evohome control the temperature. If Evohome failed to shut off the MegaFlo will shut down at 70oc then.

    If you set the MegaFlo at a similar temperature to the EvoHome there's always the possibility that the MegaFlo stat will shut off first and then the BDR91 will stay open until a time period ends. Also if you are wanting to use the Over Run the Megaflo stat will have switched the zone valve off therefore making unable to overrun. I have mine set to 55oc and a 3 minute over run which usually increases the temperature to 57oc.

  4. #14
    Automated Home Lurker
    Join Date
    Nov 2018


    Yes, that was the plan, but I didn't set the MegaFlow until I knew everything was working. It is at 70C now I think. (Though that is a guess of course, do you turn it clockwise or anticlockwise to turn it up? I guessed clockwise (remember, I couldn't really see it)).

    It all seems to be working fine, but I just noticed that the water is at 61C (set point is 59C) but the evoHome is still happily keeping the thermostat on.

    I have no boiler overrun and I checked the setpoint as 59C just now. When I press the BRD91 button the valve closes and the boiler shuts off. I guess this proves I turned the Megaflow thermostat the right way!

    I suspect that this is a communications issue. I absent mindedly put the sensor box pretty close to the BRD91 (it looked nice), but I just moved it, and hope this will solve the issue. This is the flaw in my keeping the three zone BRD91s in place. I now have five transmitters, all are 30cm+ from any other, but not much more than that. I don't know how to test the water without waiting for a long time, or setting a silly set point and changing the differential to zero.

    My only other issue is with one of my zones, which continually tells me there is an actuator fault despite working. This has only one valve. I have swapped it for two other randoms in the house, but it keeps failing. I wonder if there is a phantom bind on it, but have deleted the zone a couple of times too.

    Later: I did the silliy thing with the hot water set point and differential and the water switched on and off perfectly, so hopefully that is done! I remembered to turn it back
    Last edited by omdaddi; 14th November 2018 at 09:13 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts