Results 1 to 10 of 11

Thread: Evohome HR92 lights on but not working..

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Automated Home Jr Member
    Join Date
    Nov 2016
    Posts
    17

    Default Evohome HR92 lights on but not working..

    Hi, I have 12 HR92 in my house. One of them has stopped working. Batteries changed and it looks fine but doesnt turn (or make noise) when it should or control radiator at all. Anyone able to suggest any basic checks I can do to get to root cause please? I have checked pin on radiator moves ok and have bled it bit nothing has worked yet.. Many thanks..

  2. #2
    Automated Home Jr Member
    Join Date
    Aug 2018
    Posts
    29

    Default

    Any comms errors in the log?

  3. #3
    Automated Home Jr Member
    Join Date
    Nov 2016
    Posts
    17

    Default

    Quote Originally Posted by BuxtonJim View Post
    Any comms errors in the log?
    Nope, not a thing for that valve..

  4. #4
    Automated Home Legend
    Join Date
    Sep 2014
    Location
    Scotland
    Posts
    1,828

    Default

    Have you checked the locking latch is securely clicked in the lock position ? If not, it will refuse to operate the motor, but will not log any errors.

    Try clicking the latch back and forth between locked and unlocked a few times. Then give it a minute to see if it does its normal calibrate routine.

    Also if you had removed the HR92 from the base ensure that the black wheel is turned fully anti-clockwise before reinstalling the HR92 and clicking the locking latch to the lock position.

  5. #5
    Automated Home Legend paulockenden's Avatar
    Join Date
    Apr 2015
    Location
    South Coast
    Posts
    1,594

    Default

    Anti-clockwise?

    I thought you are supposed to screw then DOWN before attracting the body?

  6. #6
    Automated Home Legend
    Join Date
    Jan 2015
    Location
    NE UK
    Posts
    1,022

    Default

    Quote Originally Posted by paulockenden View Post
    Anti-clockwise?

    I thought you are supposed to screw then DOWN before attracting the body?
    Definitely anti-clockwise, screw it all the way out.

    When there is an issue with one HR92 it is worth trying it in a different location.

  7. #7
    Automated Home Jr Member
    Join Date
    Nov 2016
    Posts
    17

    Default

    Many thanks guys, following your advice I was able to fix it.. Cheers

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •