Results 1 to 3 of 3

Thread: OpenTherm - experiments and questions

  1. #1
    Automated Home Lurker
    Join Date
    Oct 2015
    Posts
    5

    Default OpenTherm - experiments and questions

    So...

    I have a WB Greenstar Classic 42 CDi ErP, which I've "persuaded" into giving me access to electronic data via
    a) https://en.robbshop.nl/ems-ot-opentherm-converter-nefit
    plugged into
    b) http://ihormelnyk.com/opentherm_adapter
    plugged into an ESP8266

    Which seems to be working! (Previously I have had an ESP8266 monitoring demand via relays attached to 2x zone valves and some temperature sensors.

    There's a few oddities though, maybe someone has been down this path before?

    1) The 'return' temperature value seems to return always -76.80. I'm fairly sure this is not a translation error, the raw data coming back is 0x401cb334 (the last part being the value - b334 - which is definitely negative). This is a bit disappointing since I was keen to know the CH return temp to ascertain if I was condensing or not.

    2) Similarly, the CH pressure value seems to be a constant '25.50', which is fairly obviously either not bars. Maybe it's bar*10?

    3) Not sure I understand what 'modulation ratio' is telling me - it can be 'flame on, 0%', or values up to about 26%. Higher numbers seem to tally with more gas usage not less, which is the opposite to what I expected.

    I was a bit surprised that the opentherm boiler setpoint (Tset) can be written, but not read. Indeed when I made an error attempting to read it, it just returned 0 (rather than an error - it's actually not in the spec) and set it to 0 (so no heat). Also setting a value above Tsetmax seems not to clip it to TSetMax, but to ignore you (so no heat). Not a biggie but it took me a while.

    Other than that, I was happy to see I can actually combine it with my existing 2-zone system (1x evohome, 1x "normal" system), in that the boiler temperature can be below Tset, but if there is no zone calling for heat, it keeps the CH 'off' (which happily means I think the failure mode where my ESP interface fails will continue to work based on the last ch setpoint).

    What I'm hoping is to use the current weather temperature plus which zones are enabled to adjust Tset. Zone 1 is our house, and Zone 2 is a separate small flat, so it's difficult since any temp fixed on the boiler is going to be a compromise of being too low for the house (on it's own), but too high for the flat (on it's own). I'm assuming that me setting the Tset value is broadly comparable to twiddling the 'CH temperature' dial (which sets TSetMax for OpenTherm, and I assume TSet equivalent when it's not OpenTherm)

    It's already pleasing to see temp, CH and flame data, I've a much better idea of what's going on, if only I could get at the return temps

  2. #2
    Automated Home Lurker
    Join Date
    Jan 2020
    Posts
    7

    Default

    hi this sounds interesting you could try to measure the temperature yourself. My newer worcester life has an installer menu which you can access that info from. I'm wondering how you wired it up at the boiler as I found my boiler couldn't control the firing when I used the nefit adaptor. I may have wired it wrong I have since taken it out and gone back to bdr91. Do you have any advice on the wiring side?

  3. #3
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,155

    Default

    I can help with some of this. On my Vaillant too I see CH Water Pressure as 25.5 from my Vaillant with a VR33 (eBus to OT converter). I thought that was odd, but that is exactly what both the OTB and well as the OTGW are reporting! Even 25.5 / 10 bars seems too high. However that value doesn't seem to change at all, so I just left it.
    Relative Modulation Level is actually a % representation of the Kw your boiler is using at the time. You need to track the highest and lowest % you see and then work out how to get the exact Kw based on that. My % varies from 0% to 60%. My boiler is set to 18Kw (down from 36Kw). So the 60% max I see represents the boiler working at 18Kw, so from that you can derive what the others are e.g. 30% is 9Kw and so on.
    That return temperature really seems a bit odd. Is it always that value or does it vary. Because that could easily be 64C.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •