So this is the 2nd evohome system I've had and the first time i've used the hot water kit, Previous house we just had a combi boiler

First off getting the hot water kit installed was a nightmare as we couldn't find an installer in south wales. Eventually though using the forum and some help from evohome shop I got it up and running which it worked fine for a week or two until...


I could hear the tundish activating on the cylinder. Looks like the temp wasn't reporting correctly from the sensor back to the boiler and i thought this was solved by moving unit to a better position in the airing cupboard

Again this morning i could hear the tundish dripping and after i popped the batteries in unit the temp jump straight away so it looks like the temp isn't being reported correctly back to the controller. As i work offshore my wife tells me this is actually a regular occurrence

I've tried moving the unit, changing the batteries and also playing with the battery tension

From looking at the past history it seems the hot water kit is very temperamental

Any thoughts on what to try next?