Hi
Having had the EvoHome for a while now and reading the very useful posts in this forum I'm still a little perplexed as to one particular issue.

Let me explain.

I have a S plan system to which I have two BDR91s connected - one connected to the CH valve (not the boiler fire control) and the other to the HW valve.

Also, I have a non-EvoHome UFH circuit which I have on a separate valve with "learning" thermostat.

I do not have the CH valve wedged open as per what seems to be the usual configuration.

Why like this?

Well, I have radiator valves which are not EvoHome controlled (TRVs) and I do not want them coming on when the HW is running.

Having the boiler triggered by the valves just makes sense as that is the usual non-EvoHome way.

The problem is that I still have the problem that I am trying to avoid i.e. the EvoHome fires the boiler for HW using the CH's BRD91 thinking it is "boiler control" as opposed to CH control and .........

It seems like EvoHome assumes that the system is configured primarily for CH with EvoHome rad valves and then the HW valve is added on i.e. you must have boiler control and the HW addition just adds a new valve into the mix - no pun intended.

Perhaps I should not have boiler control setup but then what fires the boiler for the CH?

I've seen references to using a 3 * BDR91 setup and am wondering if that could help?

FYI - the boiler I have is a system boiler with the pump integrated so I'm not sure if DBMandrake's solution is applicable or usable.

Thanks in advance
Mark