Results 1 to 6 of 6

Thread: Fixed my HR92 !

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Automated Home Lurker
    Join Date
    Apr 2017

    Red face Fixed my HR92 !


    Around 2 years ago a colleague at work and I went halves on a box of 4 HR92's from a fella on Ebay. They duly arrived and did indeed look brand new with all the accessories but weren't in the usual box. My plan was to have one as a spare and the other would be on an extra radiator to be added at some point.

    Wind forward two years and the new rad is in place (along with a shiny new ATAG Economiser IC35+ with an opentherm gateway) so out go the BDR91's for heating and hot water switching. All working beautifully apart from the new rad, whose HR92 would bind to the controller without issue but would not call for heat. Tried clearing the bindings and a full reset, then rebinding but no cigar. Took the head off and opened the valve fully, immediate heat so had to be HR92 related.

    So - tried the other HR92. This one failed dismally with an "E2" error, so possibly a jammed gear of faulty motor perhaps. I put that one on one side. Now I'm thinking that these 'new' HR92's were customer returns perhaps? Ah well, too late now to send them back.

    I'm an electronics engineer by trade, and inherently I'm a cheapskate who'd rather hang on to my cash, so out with the tools. It is possible to strip the HR92 down without breaking any locking tabs if you are careful.

    • Pop the top cover off and remove the batteries.
    • Pull gently on the white cog that is rotated by the top cover when you turn it. The spindle that turns the rotary encoder inside the device will pull out.
    • Undo and remove the single silver screw that can be seen.
    • You'll now see three black plastic 'barbs'. Whilst pulling gently upwards with your finger in the battery hole, use a terminal screwdriver to release each barb in turn by pushing gently on the barb (away from the motor) and the top white circular moulding with the battery cover attached will pull out.

    Now you need to get the front moulding piece off (the one with the Honeywell logo on it) - this is the more difficult bit. Use a 'spudger' - see Amazon or Ebay, the stainless steel ones are incredibly useful for this kind of job - always buy at least 2 so that one can hold a gap open whilst the other is prising the next clip.

    Start at the bottom under the display and near the retainer slide that holds the head onto the radiator valve. There are two clips here that release fairly easily and allow you to start lifting things off. Now work your way up. On each side there is another clip. Once these are released there are just two more clips at the top, one on each side. These two are the awkward ones - I found that by gently pushing in on the tops of the front moulding whilst also gently pulling outwards on the sides of the larger back moulding eventually the front moulding will pop inside of the edges of the back moulding. Once at this point the entire front moulding with pcb /display and everything will start to pivot at the top and eventually you can release the top clips without breaking anything.

    Once this is off you can see the electronics. In my case my eye was immediately drawn to the whisker of wire shorting out what I believe is the radio antenna (gold coloured) to the positive terminal with the red wire. It would be an odd circuit which has the positive supply as a reference for a transceiver antenna methinks. It looks like when the unit was manufactured, the red wire was cut but one strand remained and got pushed up against the antenna. I cleared this and reassembly was just a reverse of the above process. And it works now too so 55 saved. Happy days

    The morals of this story - 1. Not all on Ebay is what it seems (though I think we all knew that anyway didn't we?) and 2. You have nothing to lose, open it up and have a good look!

    I do have some other photo's which I took with the unit disassembled but didn't post these as it would make the thread too heavy. Happy to send these to anyone who fancies having a go though.


    Edit: - Fixed the second HR92 with the "E2" problem now as well. The connections to the pcb from the motor and the battery compartment are made by four springy metal pieces. Having got this one apart, there was no "witness mark" on one of the gold pads at the bottom of the pcb, so clearly there was insufficient contact pressure. Dabbed a 9v battery across the motor contacts once the pcb was off and the motor and gears were turning nicely. Having bent all of the 4 contacts out slightly and reassembling the unit, everything is as it should be.

    I've added some more internal photo's as I've realised that the forum seems to resize/reformat the pictures so they don't take up too much bandwidth. Hopefully these will be of use to somebody in future, if only to see where the plastic retainer clips are.

    HR92_Motor.jpgHR92_PCB.jpgHR92_PCB_Side.jpgHR92_top.jpgInteresting that there's a push switch on the pcb that is actuated via a pin sized hole in the retaining slide at the bottom of the HR92 - anyone know what this is used for? Hardware reset perhaps or a means of getting the cpu into bootloader mode to update the firmware?
    Last edited by Wobbin; 20th July 2020 at 02:14 PM. Reason: Added something....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts