Results 1 to 5 of 5

Thread: Web API Client not sending requests

  1. #1
    Automated Home Sr Member cliffwright's Avatar
    Join Date
    Mar 2007
    Posts
    82

    Default Web API Client not sending requests

    Hi All,

    I'm trying to setup a simple Web API request to ping a URL on certain conditions ... I've set this up in Cortex: it's the simplest of GET requests to a URL with no auth or params, however when I hit "Test Send", the "Raw response" pane shows "Sent Http:// .... etc" however nothing happens and I can see there's definitely no call being made to this URL in my network traffic.

    The communications log shows;

    11:26:55 IOHandler value is not valid
    11:26:55 APIClientThread closed
    11:26:56 < 9109100898041101000262

    What does this mean and how do I resolve this?

    Cheers

    C

  2. #2
    Automated Home Legend Karam's Avatar
    Join Date
    Mar 2005
    Posts
    827

    Default

    Just for clarification to others that this matter was resolved when implemented on a relatively recent version of CortexW10. So if anyone else is having difficulties doing something with the Web API client please get in touch with us directly in the meantime.

  3. #3
    Automated Home Sr Member cliffwright's Avatar
    Join Date
    Mar 2007
    Posts
    82

    Default

    Thanks Karam for your assistance in getting me up and running - the latest Dev version cured everything nicely

    Very pleased with the output :-) ... will post a description in a separate thread when I get a sec in case it's of interest to others, but I've now set things up to receive Push notifications upon certain events to attempt to combat my senior moments in life ..Very useful

  4. #4
    Automated Home Legend chris_j_hunter's Avatar
    Join Date
    Dec 2007
    Location
    North Lancashire
    Posts
    1,677

    Default

    Looking forward to that ... could be just the job !

  5. #5
    Automated Home Sr Member cliffwright's Avatar
    Join Date
    Mar 2007
    Posts
    82

    Default

    Quote Originally Posted by chris_j_hunter View Post
    Looking forward to that ... could be just the job !
    https://www.automatedhome.co.uk/vbul...-Notifications

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •