Results 1 to 2 of 2

Thread: First impression of the Mark II

  1. #1
    Automated Home Jr Member
    Join Date
    Jun 2005
    Posts
    21

    Default First impression of the Mark II

    I just got the system working and I'd like to give you my impressions on the product.

    First let me tell you something about the system I have. In the cellar I have a PC with Media Portal (a Windows MCE kind of application) installed. I have a dedicated cat5 cable running up to the first floor of the house. Using this cable I have connected a Mark II pair of boxes. (I am using s-video out from my Geforce 5500 card.)

    Once I got the cable correct the Mark II delivered extremely high quality audio and video. I had been using a wireless audio/video extender and was quite satisfied with the quality but the Mark II delivers far superior quality! Thumbs up!!

    The only flaws is the hardware itself, the power contacts and the cat5 contact on the reciever easily falls out. When you buy something that cost as much as the Mark II you expect that kind of things to be of the same quality as the rest.

    None the less I can recommend this product if you want the highest quality and have the money. The minor flaws with the contacts the won't stick isn't really a problem unless you plan to move the boxes around during operation.

    My humble opinions,

    Moltas

  2. #2

    Default Re: First impression of the Mark II

    Quote Originally Posted by moltas
    I just got the system working and I'd like to give you my impressions on the product.

    Once I got the cable correct the Mark II delivered extremely high quality audio and video. I had been using a wireless audio/video extender and was quite satisfied with the quality but the Mark II delivers far superior quality! Thumbs up!!
    Thanks Moltas. I am glad you are impressed by the quality.

    The only flaws is the hardware itself, the power contacts and the cat5 contact on the reciever easily falls out. When you buy something that cost as much as the Mark II you expect that kind of things to be of the same quality as the rest.
    I dont understand why you are having problems with this. The Power and RJ45 connectors are the same ones that have always been used and in the almost 5 years that KAT5 has been on sale this has not been commented on in the past.

    I have many units myself and have never had a problem with the security of connectors.

    I believe you are outside the UK if memory serves me correctly. Are you using power supplies that you sourced yourself, if so, do they have a 2.1mm plug. A 2.5mm plug will fit the socket but will be loose which may be the cause of your problem. The CAT5 cable should be totally secure due to the latch on the RJ45 plug.

    None the less I can recommend this product if you want the highest quality and have the money.

    My humble opinions

    Moltas
    Thanks again. Recommendation from satisfied users is always the best.

    Regards

    Keith
    KAT5.tv - affordable high quality AV Distribution
    http://www.kat5.tv

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •