Results 1 to 1 of 1

Thread: A question for Evohome HCE80 users

  1. #1

    Default A question for Evohome HCE80 users

    I have a question to Evohome users that have an HCE80 for UFH control, as well as HR92’s to control radiators: What is the cycle time of your HCE80?

    Background of my question:
    My Evohome system consists of an evotouch (latest generation), 4 UFH zones controlled by an HCE80, two zones using radiators with HR92’s, and a BDR91 on/off relay. All zones have Y87RF thermostats. I have configured the system as described in the Evohome manual (“Underfloor heating control system with a central operating device evotouch”). The UFH pump is controlled by the HCE80, while the boiler is controlled, through the BDR91, by the evotouch. My Evohome system is configured at a cycle rate of 6 per hour, i.e. every 10 minutes the boiler is switched on.

    I noticed that the HCE80 operates at a 12 minute cycle: Every 12 minutes, the UFH zone valves are opened, and the UFH pump is started.

    Because the cycle periods of the boiler and the HCE80 differ, the boiler is often switched on while the UFH pump is off, and vice versa. The issue is illustrated in the attached graph. The blue line is the power consumption of the HCE80. The green line is the water temperature into the UFH manifold.


    This seems very ineffective to me. Is this the normal mode of operation of the system, or is there something wrong with my installation/configuration?
    Attached Images Attached Images

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •