Page 1 of 4 1234 LastLast
Results 1 to 10 of 32

Thread: Anyone using Domoticz with Evohome OT + Outdoor Temperature + HGI80 (or similar)

  1. #1
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,554

    Default Anyone using Domoticz with Evohome OT + Outdoor Temperature + HGI80 (or similar)

    I just discovered that the Evohome OT Bridge will respond to quite a wide range of OT Commands over its radio.
    One of the more useful bit of information is Outdoor Temperature.
    I am keen for someone who has a natively OT compliant boiler with an Outdoor Temperature sensor connected to test my latest Domoticz change. You will need an HGI80 or similar to test this.
    You will also need to update Domoticz to the latest beta development version.
    I have added a Log message that displays the Outdoor Temperature that I calculated using the data the OT Bridge got from the boiler. I just need to see some of those messages.
    My own boiler is a Vaillant that doesn't support OT but using the VR33 it does allow an OT device to be connected. I can see Outdoor Temperature data being returned. Using that data, I have correlated the data received back to the Temperature by comparing what the Vaillant reports as the Outdoor Temperature and what the OT Bridge is reading.
    But I would like more information before I commit that change. The Evohome controller has, in the past, never queried the Outdoor Temperature. Even when weather compensation was introduced it still didn't retrieve the data from the Boiler. I want to check if there was a reason for that or if Resideo just ran out of time to implement a local sensor based weather compensation, which would have been quite useful.

  2. #2
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,554

    Default

    No one with this configuration on the forum?

  3. #3
    Automated Home Legend paulockenden's Avatar
    Join Date
    Apr 2015
    Location
    South Coast
    Posts
    1,717

    Default

    I used to have, but when I added the pre-heat tank before my Intergas combi I added the special sensor for this, and that seemed to clash with the outside temp sensor, so that got ditched.

  4. #4
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,554

    Default

    I am getting back data from my Outdoor sensor, which seems to change exactly in relation to the actual temperature but I can't make any sense of the data I am getting.
    So I am trying to figure out where the problem might be.
    I am going from Domoticz-> HGI80-> OTB-> VR33-> Outdoor sensor.
    So I have no idea if there is an issue in the VR33s translation between eBUS data to OT data.
    Or that its the OTB that is causing the problem.
    Or my Domoticz implementation.
    Thing is, I am using the same code to query the other boiler parameters and that seems to work fine. But then again, the Evohome never queried the Outdoor Temperature from the OTB before. And maybe, the bug I have stumbled on is the reason why Resideo "ran out of time" to implement Evohome weather compensation using the local boiler's outdoor sensor.

  5. #5
    Automated Home Guru
    Join Date
    Sep 2018
    Location
    Scotland
    Posts
    175

    Default

    Quote Originally Posted by bruce_miranda View Post
    I am getting back data from my Outdoor sensor, which seems to change exactly in relation to the actual temperature but I can't make any sense of the data I am getting.
    So I am trying to figure out where the problem might be.
    I am going from Domoticz-> HGI80-> OTB-> VR33-> Outdoor sensor.
    So I have no idea if there is an issue in the VR33s translation between eBUS data to OT data.
    Or that its the OTB that is causing the problem.
    Or my Domoticz implementation.
    Thing is, I am using the same code to query the other boiler parameters and that seems to work fine. But then again, the Evohome never queried the Outdoor Temperature from the OTB before. And maybe, the bug I have stumbled on is the reason why Resideo "ran out of time" to implement Evohome weather compensation using the local boiler's outdoor sensor.
    Stick an OTGW between the OTB and VR33? That should tell you whether the Domoticz->HGI80->OTB path is working, returning the same value.

    We know OTB->Boiler->Outdoor sensor works. The OTB regularly requests the Outside temperature. So if the OTGW is reading a nonsense value it's likely to be your VR33 that is the issue.

  6. #6
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,554

    Default

    Kevin, are you saying you have actually seen the OTB request the outside temperature ID: 1B from the boiler? I wonder why it does that thought. That data is going nowhere. Evohome wasn't pulling it before the latest firmware update and not infact pulls no OT data any more.

  7. #7
    Automated Home Guru
    Join Date
    Sep 2018
    Location
    Scotland
    Posts
    175

    Default

    Quote Originally Posted by bruce_miranda View Post
    Kevin, are you saying you have actually seen the OTB request the outside temperature ID: 1B from the boiler? I wonder why it does that thought. That data is going nowhere. Evohome wasn't pulling it before the latest firmware update and not infact pulls no OT data any more.
    Yes, that's right, approximately every 1m 45s. It's not OTGW initiated, it is coming from the OTB (T for Thermostat, B for Boiler):

    00:01:06.465029 T001B0000 Read-Data Outside temperature: 0.00
    00:01:06.777600 B401B0400 Read-Ack Outside temperature: 4.00

    When I first saw this, it was the original motivation behind me modifying the OTGW firmware to support weather compensation.

  8. #8
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,554

    Default

    Very interesting. Could you please show me some more of these temperature messages, especially if you have the actual temperatures too. And definitely when the temperature is above 16C outside.

  9. #9
    Automated Home Guru
    Join Date
    Sep 2018
    Location
    Scotland
    Posts
    175

    Default

    From my previous house with Intergas boiler. The Intergas boiler returns fractional temperatures, its sensor was very accurate according to my Netatmo weather station.

    01:42:24.375260 T001B0000 Read-Data Outside temperature: 0.00
    01:42:24.471559 B401B04CA Read-Ack Outside temperature: 4.79
    ...
    01:43:24.893382 T001B0000 Read-Data Outside temperature: 0.00
    01:43:25.018012 B401B04D1 Read-Ack Outside temperature: 4.82

    It was read approximately every 60 seconds.

    My Vokera sensor is less accurate, always an integer and typically 1C higher than my Netatmo. Seems to be read less frequently. I wonder if this is due to the latest firmware, maybe someone else can confirm.

    22:11:07.679883 T001B0000 Read-Data Outside temperature: 0.00
    22:11:07.890209 BC01B0600 Read-Ack Outside temperature: 6.00
    ...
    22:12:55.586279 T001B0000 Read-Data Outside temperature: 0.00
    22:12:55.597772 BC01B0600 Read-Ack Outside temperature: 6.00

    My current outside temperature is 5.6C. You'll have to wait a few weeks for me to see >16C, I'm in Scotland.

  10. #10
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,554

    Default

    The Evohome firmware upgrade cannot impact the frequency at which the OTB requests the boiler for the outside temperature. It could however be that the two OTB units that you have, have different OTB firmware versions in them. As I said, the latest Evohome firmware has infact stopped requesting ANY boiler data from the OTB. And it never requested Outside Temperature data. So the fact that the OTB requests that from the Boiler is quite surprising.
    Your data provided above is super useful.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •