Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: Anyone using Domoticz with Evohome OT + Outdoor Temperature + HGI80 (or similar)

  1. #11
    Automated Home Guru
    Join Date
    Sep 2018
    Location
    Scotland
    Posts
    175

    Default

    Quote Originally Posted by bruce_miranda View Post
    The Evohome firmware upgrade cannot impact the frequency at which the OTB requests the boiler for the outside temperature. It could however be that the two OTB units that you have, have different OTB firmware versions in them. As I said, the latest Evohome firmware has infact stopped requesting ANY boiler data from the OTB. And it never requested Outside Temperature data. So the fact that the OTB requests that from the Boiler is quite surprising.
    Your data provided above is super useful.
    Bruce, how often does the Evohome controller communicate with the OTB? Maybe that frequency has changed and that influences how often the OTB reads boiler parameters. There are several other requests like return water temperature read at around the same rate.

  2. #12
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,541

    Default

    So previously, Evohome would request the boiler stats from the OTB every 5mins. It doesn't do that any more. It used to request the Control Setpoint and Flame status every minute, it doesn't do that either.

  3. #13
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,541

    Default

    My OTGW sat unused for over a year and the moment I decide to sell it, because it made little sense to my setup, I could do with one - Typical isn't it.
    In any case, what I was trying to do was provide a way for users to see and track Outside temperature. But it looks like the VR33 might be the issue here. It's still worth implementing because looking at the above it shows that on a native OT boiler the data is valid.

  4. #14
    Automated Home Guru
    Join Date
    Sep 2018
    Location
    Scotland
    Posts
    175

    Default

    opentherm1.JPG
    opentherm2.JPG

    Here are all the types of requests seen by my OTGW. You can see there are a bunch of them with a period of around 1m45s.

    The DHW ones are odd, because Evohome doesn't distinguish between CH and DHW from an OpenTherm control perspective.

    Most likely the R8810A OTB has been designed to also handle other controllers.

    I should say though that some of them are inserted by the OTGW. Basically if it knows that an ID is not supported by the boiler it will replace it with an alternative ID to read additional information. Burner operation hours is an example of that, but my boiler just returns 0 for it, the Intergas does provide actual values.
    Last edited by kevinsmart; 26th February 2021 at 02:05 PM.

  5. #15
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,541

    Default

    That is quite clear evidence that the OTB is doing a lot more than is being instructed by Evohome.

  6. #16
    Automated Home Jr Member
    Join Date
    Sep 2018
    Posts
    40

    Default

    I do
    Boiler is Perfinox 4100, is reporting the external temperature on the system itself.
    It should respond to regular OT request, as the internal electronic card is OT compliant (Siemens LMU64)
    and as you know bruce, i have an HGI + OTB in my setup

    I do have a OTGW, but I'm a bit lazy in connecting it up (and most importantly finishing up the network connexion of the OTGW)
    Last edited by oxygen; 1st March 2021 at 12:05 PM.

  7. #17
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,541

    Default

    If you have access to the latest Domoticz Beta, could you please download and run that. Confirm that all your OT devices that had stopped updating have started updating again, every 5 mins. Once you confirm that, I'd like to ask you to try something in your local Domoticz wrt Outside Temperature. I coded everything and kept ready, but for some reason the data I was getting back from my OTB wasn't compliant to the OT Protocol. I am now convinced that is an issue with the VR33 that I use rather than my code or the OTB. Even without making any changes you should see these Outside Temperature messages displayed in the Domoticz Status log.

  8. #18
    Automated Home Jr Member
    Join Date
    Sep 2018
    Posts
    40

    Default

    Done for the upgrade to latest beta.

    Pending for the missing data, seems that the data is coming back online (but slower than every 5 mins)
    I've virtually everything back (apart from pressure & OEM error codes).

    Here is the two usefull data I have:
    2021-03-01 14:11:40.239 Status: evohome: opentherm bridge detected, ID:0x29aa77
    2021-03-01 14:11:40.239 Status: evohome: OPENTHERM_BRIDGE: Outside Temperature = 1.09 C 11 68
    [...]
    2021-03-01 14:16:35.507 Status: evohome: opentherm bridge detected, ID:0x29aa77
    2021-03-01 14:16:36.561 Status: evohome: WARNING unrecognised message structure - possible corrupt message '00C012016B' (3)


    I need to go and have a look at the actual outside temp to confirm the reading because I'm quite sure it's warmer than 1.09C
    (OpenWeather says approx 13C)

    Update on the value reported:
    2021-03-01 14:26:40.738 Status: evohome: opentherm bridge detected, ID:0x29aa77
    2021-03-01 14:26:40.738 Status: evohome: OPENTHERM_BRIDGE: Outside Temperature = 0.97 C 0F 74
    Last edited by oxygen; 1st March 2021 at 01:27 PM.

  9. #19
    Automated Home Legend
    Join Date
    Jul 2014
    Posts
    1,541

    Default

    The new code needs to first detect that you have an OTB in your system. That process can take a few minutes, but once it detects an OTB, it will start requesting the OT data every 5 mins, as before.

  10. #20
    Automated Home Jr Member
    Join Date
    Sep 2018
    Posts
    40

    Default

    Yup, everything is now properly reported.
    External Temperature reading seems to be quite off though.

    New value:
    2021-03-01 14:41:40.977 Status: evohome: OPENTHERM_BRIDGE: Outside Temperature = 0.93 C 0E D8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •