My Evotouch is running and I have recently switched it to "Eco" mode as I normally do at this time of year.

This is correctly reducing the setpoints of the zones by 3C. This sometimes means a zone ends up colder than I would like, so I use an override to push it up.

However, overrides are not working!

If I use the app to set an override, it initially shows the new temperature, but it soon switches back to a lower one. A couple of examples:

1) The lounge was set to 16C (schedule is for 19C). I used the app to set it to 19C - the app show it set to 19C for a while, but it then drops back to 16C without me doing anything or there being a schedule change.
2) The office was set to 13C (scheduled value). I used the app to change it to 21C. The setting has just changed to 18C (which is 3C below what I set it to, which can't be a coincidence).

I have a DTS92 in the office and have tried using the buttons on it to push the temperature up. This also does not work, and the display shows unexpected behaviour - e.g., it starts at 13, I press up" a few times and it shows 13.5, 14.0, 14.5, 15.0, 15.5, 13.0 - note the back step).

Changes made on the Evotouch itself also do not take effect.

I have reset the Evotouch, but that made no difference.

Overrides work as expected if I deactivate Eco mode.

I have tried reporting this to Resideo support by email, but the person handling the case does not seem to understand the issue - I have been told "The temperature drop in the Economy mode cannot be adjusted" and "Please be informed that in Eco mode you can do temperature changes (overrides)".

Has anyone else seen anything like this?