Results 1 to 2 of 2

Thread: Evohome DHW overshoot c8degrees

  1. #1
    Automated Home Jr Member
    Join Date
    Jan 2019
    Posts
    25

    Default Evohome DHW overshoot c8degrees

    Hi all,

    Had evohome for a few years now, with DHW.

    I recently (3 days) ago had a new boiler installed and moved to OpenTherm from the previous on/off switched live. Boiler is an Ideal Logic Max System

    The OT is working brilliantly and is already learning the required heat to maintain a consistent temperature, however since then my DHW has been consistently over shooting.

    I think there are 3 options why this is happening…

    1. Issues with DHW valve slow closing (not passing as DHW is a consistent temp when CH on)

    2. Some fundamental confusion on the evohome/OpenTherm causing it to massively overshoot its set point.

    3. Previous boiler flow temp was set too low (no idea what is was as complete analogue control) and evohome has learned to keep the DHW valve open longer as it approaches set point.

    I’ve refreshed the batteries in the temp sensor so it’s not that.

    I’m hoping that it’s number 3, and evohome will relearn. I could try clearing the DHW binding but I remember it being a pain to get it right last time so not sure I want to do that unless I have too.

    Anyone have any other ideas on what may be wrong?

    Thanks

  2. #2
    Automated Home Jr Member
    Join Date
    Feb 2019
    Posts
    42

    Default

    Happened to me 3 months after installation. It was the insertion sensor for the unvented cylinder attached to the CS92A which was replaced under warranty.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •