Results 1 to 3 of 3

Thread: xAP installations

  1. #1
    Automated Home Sr Member kev_t's Avatar
    Join Date
    Jun 2004
    Location
    Lincolnshire
    Posts
    58

    Default xAP installations

    Some simple questions/comments...

    I have installed the Homeseer plugin, the service mode Hub and viewer, and have been playing with some of the other xAP apps

    It is not clear if there is a preferred or desired directory structure for the xAP apps, at the moment I have them in c:\xap.

    Some of the apps require cygwin, I made the mistake of downloading the whole package, when all I really needed was cygwin1.dll. This is not clear in the descriptions I have seen. Again I have placed this file in c:\xap

    Its probably just the difference between what a developer knows he needs and what an "end-user" actually needs to make it all work

    Your advice appreciated

    Kevin

  2. #2
    Automated Home Jr Member
    Join Date
    Mar 2004
    Posts
    15

    Default Re: xAP installations

    Kevin,

    The apps from mi4.biz and xapframework.net tend include a windows installer. They install to c:\program files\xAP XX where XX is the app name. As you have seen Patrick's apps come a zip files, these can be unzipped anywhere but c:\xAP\app name is probably the neatest. I have an installer in the downloads section of mi4 to install the cygwin1.dll and get it registered which makes things alot easier. ( it gets placed in system32 usually)

    I am assuming that the apps are all running and that in viewer you are getting a nice tree of all the xAP items that are running on the network. Beta2 of the homeseer plugin was recently posted to the hs fourm and on mi4. It includes a good few bug fixes and adds more integrated IR functionality as well as support for the red rat.

    We are very aware of the documentation issues and lots of work is currently being done to make things much easier to find. There is alot of xAP info/guides/documentation out there but it spread out and need centralising, this is what we are working on ! Thanks for the comments I will make sure the info on cygwin gets added to the help as well as recomending good file locations.

    Many thanks

    James
    mi4.biz

  3. #3
    Automated Home Sr Member kev_t's Avatar
    Join Date
    Jun 2004
    Location
    Lincolnshire
    Posts
    58

    Default Re: xAP installations

    James

    Thanks for your response and clarification, I will straighten it out tonight probably

    The homeseer plugin and viewer is running fine. The box it is on is new so I am having some small problems with moving homeseer from the existing box which was pretty low spec and running Windows 98. Some of the stuff you are doing and I want to use seemed to need some more oomph, so I bit the bullet. Yes running your Beta 2 from the HS board, no excessive CPU, but I havent pluggged in the CM12 yet

    Please dont take my comments as criticism, we all tend to want to make things work rather than write about how we did it The documentation is certainly getting better and hopefully this will encourage wider adoption

    One small question, I notice in the viewer that housecodes A to P have their own branch under the housecode (this is from memory so excuse any slight errors) but the other, virtual devices seem to have arbutary "housecodes". Do you understand what I mean? Anyway just wondered what the reasoning was?


    kevin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •